Opera WM 9.5 beta trash (tries to handle) WWM display (yuck)

I got Weather Watcher Mobile (WWM) 1.0.8 on my Sprint Touch (Vogue) and love it… compared with the incessant weather stuff that comes with the Touch (seriously, does one really need a weather update every 30secs?).

But then I loaded Opera WM 9.5 beta and it completely tries to take over the display duties used by WWM… which is weird because I never noticed that PIE (or any browser for that matter) was being used by WWM in doing its display. Nevertheless it seems to be so – I gather that WWM calls some HTML rendering engine to do its work and Opera 9.5 decided (unilaterally) that it was better than the stock HTML engine.

Anyways, its a mess – How can I fix it so that WWM is the way it was ?

(thx for a great app…)

You have to set PIE as your default web browser. Right now, there is no other way around this setting.

Do you know of a specific way to do that, or to force PIE to be the default browser ? (or only to try to prevent some other browser from asserting itself…)

The simplest way to solve the problem is to get rid of the Opera beta. If you delete it make sure it’s not set as the default browser or you’ll have a problem after it’s gone.

Sure, but actually Opera 9.5 has some pretty nice features… and if it ever gets released for real, there’s at least a passing chance that it will do the same thing the beta does. Not to mention the myriad other WM browsers out there (Mozilla, Skyfire, Netfront, Picsel, etc, etc) that may well try to also be the default browser. So it seems reasonable to suggest that Weather Watcher may well have to deal with this sort of thing in the future and figure out a way to dictate which HTML engine it uses (i.e. PIE).

FYI, the latest beta of OperaWM 9.5 does not trash the registry quite as bad as the previous version, and thus it is possible to keep it from taking over all HTML rendering duties by default. So things are ok for now.

However it still seems like Weather Watcher needs to be able to specific PIE for its rendering engine instead of just relying on the default, whatever that might be…

I just received my HTC Touch Diamond and the first soft I wanted to install was Weather Watcher. Unfortunatelly, as Monkeyboy described it, Weather Watcher is not usable anymore when Opera is installed. Furthermore, I cannot uninstall Opera because HTC installed it with Windows Mobile (nothing in add/remove program).

Does anybody know how to set IE as default ?
Will SingerCreations publish an update ?

VIK, try searching here:

Not sure if this will help everyone or not, but I noticed that the setting to turn off Opera as the default browser is kind of hidden. You have to go to Opera’s settings-advanced and then scroll down. They don’t have a scroll bar, so at first I didn’t think there were any more options. However, just use your finger to scroll and the option is at the bottom. Hope this helps someone out!

Thanks for your help but I don’t have this option. I just made the last ROM update on the HTC Touch Diamond but it seems that the option default has been removed. Singer’sCreations should have more interest for this problem, because the Touch Diamond will be the most sold PDA in a few time…

Hi Mike,

Have you given any more thought to addressing this issue? As the previous poster noted, HTC devices are starting to come with Opera in the ROM. While there probably is still a way to set IE to be the default, I don’t want to do that. I actually like Opera quite a bit as it has matured. Can you setup WWM to explicitly use IE instead of relying on a default browser? With more WM browsers coming (Opera, FireFox, Skyfire, etc), I think more and more people may end up without IE as their default. The Sprint Diamond is selling very well, and the new Sprint Touch Pro (which I just bought) has been selling very well in the week it’s been out as well. WWM won’t work with either of these devices because of the default Opera that’s built into the ROM.

I do recognize that it’s a free app, and I always hate to be too demanding on a free app! I can’t complain if you say you can’t or don’t want to address this. :slight_smile: But I just wanted to point out that the app may not work for a growing segment of potential users.


Yes, I would like to resolve this issue, but it’s likely that it might be out of my hands if it’s an issue with Opera.

Weather Watcher Mobile uses Microsoft’s web browser control to display the weather data. I’m not sure why the web browser control does not work properly when Opera is set as the default web browser. I tried googling for some answers, but was unable to find anything but a few posts from people experiencing the same issue.

Hello Mike,

Finally, I found an interesting option in Opera : “settings” - “display” - “mobile view”.

With this option activated, your page is correctly displayed in Opera, and I can use again the best weather tool.


That doesn’t do anything helpful for me on my Touch Pro – it still launches Opera to display the weather page that WWM has put together within Opera. It lacks the navigation, so I have to minimize Opera and go back to WWM to switch tabs.

I have been using Opera since late July Build 9.51b1 and have found it to be outstanding except for its lack of SIP support. I can not imagine going back to ANY other browser. This version allows turning off Opera as default browser as the last option (scroll to bottom) in the Advanced tab and this does solve the WWP problem. I have also tested the new 1b2 version that just came out in late Oct and couldn’t get it to run without crashing.

http://ftp.opera.com/pub/opera/winmobil … _951b1.cab


SKTools has facility to choose your default browser. I think this is available in trial mode.

I’ve been trying a few different Opera 9.5 builds so have needed to use SKTools every time I install a newer version of Opera.

By the way, there are much later builds than the official beta which are much better. See:

Hello graefnz

I tried your recoommended Opera download at xda-developers.com and that htc version does not have the checkbox to turn off Opera as a default browser so it in itself doesn’t solve the problem. I also prefer the graphics in the 1b1 build myself :wink: .

Yes you are right it doesn’t have an option in Opera

But, as I said, I use SKTools to change the default browser.

Just got an HTC Touch Pro today and now have this issue.

Couldn’t you just hardcode WW Mobile to access PIE instead of relying on the default WM browser setting?

Not sure if that’s possible, but that would be a nice solution.

As it stands now, WW Mobile isn’t really usable.


I’ve managed to get Weather Watcher to function on my AT&T HTC Fuze (HTC Touch Pro) with Opera still installed as the default browser. This is a really cool app – thanks! – so I wanted to share what I’ve learned in hopes that it will help someone else. (This assumes that you’re at least passingly familiar with editing the Windows registry.)

It appears that Weather Watcher just creates .html files for the various views and then launches them. That relies on the normal file association mechanism, i.e., it uses the value of the registry key HKCR.html\Default as an indirect to another key in HKCR to determine the launch action. With Opera as the default browser, that value is _htmlfile_Opera, so Windows executes the command given in HKCR_htmlfile_Opera\Shell\Open\Command\Default to launch the .html file.

The simplest edit would be to change the value of that key, HKCR_htmlfile_Opera\Shell\Open\Command\Default, from its default value of “\Windows\OperaL.exe” “%1” to

iexplore.exe file: %1

However, making just that change would leave the icon for the various files in File Explorer as the Opera icon instead of the Internet Explorer icon. It also changes the file associations for several other suffixes, not just .html files. Also, it just “feels wrong” to change the application referred to in a key named _html_Opera to be something other than Opera. I wanted to make the change with the smallest impact possible and also to be consistent, so what I did was:

  1. Clone the HKCR_html_Opera subtree to a new subtree named _html_iexplore (this is really easy in Total Commander’s registry editor, I don’t know about others).

  2. Change HKCR_html_iexplore\DefaultIcon\Default to have the value iexplore.exe,-1003.

  3. Change HKCR_html_iexplore\Shell\Open\Command\Default to have the value “iexplore.exe file: %1” (without the quotes).

  4. Change HKCR.html\Default to have the value _html_iexplore.

This still leaves the file associations for .htm and .xml using Opera instead of Internet Explorer.

Anyhow, Weather Watcher now works, and Opera is still the default browser for everything except local .html files.

Hope this helps.