Motorola Q Support?

I just tried the new 1.0.0 smartphone version on my Verizon Motorola Q.

It takes a long time to install for some reason. Once it does and I try to run it, I get a wm5 crash error before it opens. Didn’t really give me any error details.

Has anyone tried this on a Q?

Works fine on my T-Mobile Dash.

I see you were already posting in the forums below, but it’s the best source I could find. There seems to be a bug in the Q’s latest update.

Well, I don’t know. My Q works fine with plenty of .NET CF programs.

I see some people get your newest version to run and some don’t.

I’d be happy to send you any logs if that might help you figure out what the problem is? I just don’t know where the error log files are stored.

Your program looks very promising so I’d love to get it working on my Q.

Any ideas?

It looks like the applications that use the Internet Browser control do not work. A lot of applications do not use that control, so that’s most likely why you’re not noticing the problem with your other applications.

Unfortunately, I don’t think there is anything I can do. It looks like Motorola needs to fix the bug on their end.

I put together a small application that does nothing other than display a web browser control. This will be a good test to see if the web browser control is really causing the isssue.

Just download the above EXE and run it on your Q – there is no installer, etc.

That ran successfully on my Q.

When the application opened, did you see the Google homepage load up in the main window?


Cool. When you attempt to run Weather Watcher Mobile, do you see anything open? Is “wm5 crash” the exact error message?

I click the weather watcher icon, then I get an error saying

We’re Sorry (which is up at the top)

A problem has occurred with weather watcher.exe

Then it gives me the option to report it to MS and gives me a link to show report details.

If I do that, there’s a LOT of data there, but I’m not sure if/where it saves that file on my Q if you wanted me to get it off there and send it to you.

I’m not sure where (if it even does) saves the details. Is there any way to copy/paste the details into an e-mail?

No, I don’t see how I could cut and paste the error message. If it’s on the Q, I can get it, but I don’t know how I’d do it otherwise. It was a lot of data.

Here’s the beginning
EvntType: WinCE501bBEX
AppName: WeatherWeatcher.ex
Mod Name: itap6ime.dll

Maybe that means it’s a problem in the itap dll? Some call to that could be the problem?

Here’s a little more that might help

Faulting Thread 0x81A3045E

There’s a few other things, but the rest is mostly just hex stuff.

Try installing the following Weather Watcher Mobile test build:

What do you see when you run it?

It crashed after step 4.

That’s right when the interface loads. This looks like an issue Motorola is going to have to fix…

Ok, well i’ll delete this and move on…if you ever do figure out anything on your end or have any other tests for me to try, let me know.

I can’t imagine Motorola jumping to fix whatever it is the problem is.


If I may jump in here. There was an update to the Q that we had to do in January. I installed WW on my Q and it seemed to install fine. When I start the program it appears to start but nothing shows anywhere. The phone does not lock up or crash. I just don’t see WW any place. I check the task manager and WW does not show up.

Everyone who contacted me with those symptoms did not install the .NET Compact Framework on their mobile devices. Do you fall into that group?

As I recall from reading some forums, Weather Watcher Mobile only starts to crash at startup after installing both the .NET Compact Framework 2.0 and the latest Q update.

I had the .net 2.0 installed before I loaded WW.

Microsoft currently offers two versions of the .NET Compact Framework 2.0. I’m wondering if the older version of the framework will work… or the newer version if you already tried the newer version.