dayllight time remaining

daylight time remaining not working :sad:
it say (0)zero

It’s working for me. I don’t normally use it but I just set it on and did a weather update and it displayed a valid time.

The Daylight Remaining field in my tray tooltip also says “0 Minutes” all day long.

I’ve seen it work on another machine though, but that machine went through a couple updates. This one was clean and installed 5.6.16 from scratch.

Daylight remaining still says zero in 5.6.18. ZIP: 60173

I found a small bug in the function that calculate the remaining daylight time. You can download the fixed build from the following link: … =8055#8055

Please let me know if this build resolves the issue.

The following build fixes a bug that was causing the tooltip “Daylight Remaining” value to display as “0:00” when the remaining daylight time was between 0 - 60 minutes.
It doesn’t, probably because there are like 8 hours of daylight remaining, far more than 60 minutes.

I was running version 5.6.18 and my Daylight Remaining always showed zero also.

I downloaded 5.6.18A from the link in a previous post, installed it (w/o de-installing the previous version) and Weather.Watcher crashed w/ runtime err 91 (I think) on startup.

I de-installed Weather.Watcher, re-installed version 5.6.18A, it starts up fine now and the Daylight Remaining now shows the correct amount of time.

Basically - it fixed it for me.

Thanks to Mike S. for the quick fix.

Regards, MikeE3

I’ve seen this issue before, but I have not been able to reproduce it… which is a necessary step in fixing a problem. There is an issue somewhere in the process that loads the skin into the interface when Weather Watcher starts up. That’s about all I could figure out at this point.

As a fellow developer, I sympathize. If you’d like me to run debug builds or send you log files or whatever, just let me know.

Mike S.

I didn’t mean to hijack this thread about the runtime error. I thought maybe it was just because I installed the ‘A’ version without uninstalling the previouis one first. I wasn’t sure if I had/should do the unistall first.

I’ve been in this computer business since 1967 and some things just don’t change - it sure a tremendous help to be able to reproduce the error as a first step in solving the problem.

My real intention for the post was to report that the ‘A’ update fixed the Remaing Hours problem for me.

Best Regards, MikeE3

Interesting. An IBM 360 maybe?

Actually I think my first was an IBM 1402 (or 6) that didn’t even have an arithmetic chip yet. It did it’s math using table look ups, like on the back of the old black Composition notebooks we had in grammar school with the mulitplication tables printed on their back cover.

And even then we had ‘hackers’. Some ‘industrious’ student once altered the tables and 2 + 2 was showing up as 5.

The IBM 360 20’s and 40’s came soon after that. From there I went to the Univac II’s and III’s and the Univac 1100’s.

Regards, MikeE

And I was starting to feel big after only 17 years. I least I was born a few years before that.

Ah yes, well you did start before me. :lol: The 1403 was the printer I think and it was a work horse for years.

Dang whippersnapper. :iconbiggrin:

Since we’ve gotten a bit off-topic, I thought I’d ask if there were any further thoughts on this bug. :slight_smile:

I cannot think of anything else. It’s working for me… I even tried checking the weather at your zip code.

Are the sunrise and sunset times displaying properly in the “Current” Weather Watcher view?


FYI: 5.6.20a still isn’t displaying Daylight Remaining (although the Sunrise and Sunset times are displayed correctly).

I know this is entirely off-topic but I couldn’t resist… my first computer was an IBM 1620, TTL logic and 4K of core memory, cards in and Selectric typewriter out. We programmed in Fortran II by loading the compiler card deck (about 2 feet of it) followed by the source deck and punching an object deck, which we then loaded and ran. Made one rather careful about proof-reading the source… This was 1965; I was in high school.

Ah, the memories! :slight_smile:

Back on topic:

I’ve been checking and occasionally I do get this kind of behavior, although I haven’t noticed it lately. Currently running Weather Watcher 5.6.20c

Off topic topic:

[size=2]I suppose the first “computer” I officially used was some kind of HP desktop programmable calculator in 1978 when I was in high school. It also used the Selectric typewriter for output. The thing was programmed using an optical card reader and base 8 mnemonics. The coolest thing we wrote was a moon lander simulation. The deck was about 6 inches thick. The following year we had some home brew kit programmed using Southwest BASIC. The year after I graduated, the HS got TRS (Trash) 80s. I didn’t get paid to work on anything until 11 years later.[/size]