Daily page is blank. Bottom of Current page is blank

Hi Everyone,

  1. The short version is: "What domain can I include in my Internet Explorer “Trusted Zone” in order for the WW Daily and Bottom pages to display?

Here is the long version.
2) I realize that WW uses MSIE as its display engine. I normally use MSIE with the “Internet Zone” security set to High. That affords me quite a bit of protection while surfing so that new/unknown websites have very few rights on my computer. When I know of a website that I trust and need to allow it more rights, I simply double-click on the Internet zone icon in the bottom right of IE’s status bar, and add the site to the Trusted Zone. Even my Trusted Zone is set to Medium-High security, so sites still do not get too many rights on my computer.

  1. With the Internet Zone set to High security, WW displays the Daily page as blank and the bottom of the Current page as blank. When I reduce the Internet Zone to Medium-High, those WW pages display properly.

  2. I reset the Internet Zone to High, then began going through all of the custom security rights for the High zone and changint them, until I found the one that WW needs. I found it near the bottom of the list under Scripting. It is “Active Scripting”. When I change that one right to Enable from the defaults for High security, then WW is able to properly display the Daily and Current pages.

  3. That right is enabled in my Trusted Zone. “*.SingersCreations.com” is already in my Trusted Zone

  4. Sooooooooo, my question is: "What domain can I include in my Internet Explorer “Trusted Zone” in order for the WW Daily and Current pages to properly display?

OR, how may I leave the Internet Zone on the default settings for High security and get WW to display those pages properly?

Thank you,
– Patrick B.

Which version of IE are you using? If you’re using 7, you could tray the solution that whatever posted at the following link:


Thank you for the pointer to the other topic Mike. I had looked a few days ago and found nothing on this subject. I should have looked again prior to posting.

Anyway, I believe I have discovered another solution, but would like someone else to try it out.

  1. Navigate to the folder:
    c:\Program Files\Weather Watcher\Skins\Forecasts\Classic

  2. Double-click on any WTP file

  3. Choose to “Select Program from list”

  4. Choose Notepad. Make sure the “Always use …” checkbox is checked.

  5. Open the Skin options in WW and reselect Classic or whatever your normal skin may be.

  6. Open the Daily forecast page in WW while you have the MSIE Internet Zone set to High security.

This works for me on 2 machines. Anyone else?

Thank you,

– Patrick B.

Are you saying that, when you open it in Notepad, with IE open with the High Security settings enabled, that you make the file association for .WTP files and notepad, or just open it that one time?


I mean that I set the file association for WTP files to be opened by Notepad when I double-click a WTP file. … not that I expect to every open a WTP file again.

Afterwards, the WW Daily screen displays normally with MSIE set to High Security for the Internet Zone.

This surprising fix is still working after rebooting. I do not understand the reason why, but it works and requires no reinstallation and no change to a WTP file and no creation of a personal skin.

Best of all, I can retain my High MSIE Internet Zone security at its default settings. :iconbiggrin:

– Patrick B

it works quite possibly because you have the file associated with a trusted program on your computer, a program that Windows and IE both recognize as being valid.

At least that is my theory :wink:

Well, this issue is back. All of the information in my original post still applies, AND I still have WTP files set to open with Notepad, SO that fix no longer works.

I generally do use Firefox now, but of course WW uses the MSIE engine.

Any new suggestions on how to see the Weekly forecast window and still leave MSIE’s Internet Zone on High security?

Also, the Weekly forecast window is not quite wide enough and no longer allows itself to have its size changed.

– Patrick B.

Can you post a screen shot of what you are seeing? I’m not sure what a Weekly forecast window is.


Ok, that is the Daily forecast window. And it looks fine to me. Can you post a screen shot showing the problems you’re encountering?

Hi Ed,

You know, for as long as I have been using WW, I should have known that was the “Daily” page, but all I do is double-click on the temp icon and get the forecast for the week, so I have always thought of it as the Weekly forecast. Oh well.

I must have been a little tired when I posted that picture to not realize it was not blank. At the time, I had MSIE 7’s Internet Zone set to “Medium High” security, so the page did display. It did, though, show the size of the WW window that I could not change the size of.

Here’s the good news. If I am very, very careful, I can manage to get the mouse pointer to change to a double arrow so I can adjust the size of the WW window. Apparently the drag zone is only 1 pixel wide for that window and I find that I can play around for several seconds before getting the double arrow to show. I can live with that, but it would certainly be helpful if the drag zone were a little larger. In MSIE itself, the drag zone appears to be 3 or 4 pixels wide – and in the bottom right corner, MSIE has an entire corner to allow changing of the size.

The bad news is that once I put MSIE’s Internet Zone back to “High”, WW’s Daily forecast appeared to be blank. The sort of good news is that once I scroll down, I see the rest of the information. Could “High” be blocking some script that properly formats the data? Other than reducing the Internet Zone to less than “High”, how can I get the Daily forecast page to properly display?

Thank you so much,

Patrick B.



In the Splendid Interface skins’ folder is an .ini file. In it is this lineDragWidth=5 If you change the 5 to say 10 it should make finding the double arrow easier to find.

And try making the “Weekly” window extra wide and see if the display changes. If not, while leaving it extra wide, refresh the forecast.

Let us know what happens.

Thank you for the suggestions Ed. I did change the DragWidth to 10 and now realize that this WW window has no dragability on the left, the top, or the on the right – until you are parallel to the scrollbar. I normally drag with the top-right or bottom-right corner, so that was confusing me a bit. That part I can live with.

Still have the oddly formatted window unless I take MSIE’s Internet Zone off of High security.

Patrick B.


The WW Interfaces are dragable on the right edge, bottom edge and bottom right corner. Needless to say positioning the window in the lower right hand corner limits it’s expandability until it’s moved.

As for why changing the IE Internet Zone level I have no idea what the problem could be. Have you tried a different Forecast Interface skin and have the same problem with the Daily forecast?

Good news! changing the “Interface Skin” and the “Forecast Skin” to Classic has resolved the issue for me. The bottom three skin options were already set to Classic. I compared the two Daily.wtp files, but did not come to any solid conclusion on why Splendid is broken when MSIE’s Internet Zone is set to high.

A wild guess would be that it has something to do with the use of relative paths instead of absolute paths. Steve and Leo were talking about relative paths in episode 186 of Security Now. If you are interested, search for “Bill in Auckland” on this page: http://www.grc.com/sn/sn-186.htm.

Thanks again Ed for leading me to a solution!

– Patrick B.

Ok!! Good to hear you’ve made some progress. =D>

My final suggestion is to:

Rename the Splendid Forecast skin’s DAILY.WTP to DAILYX.WTP.

COPY the Classic Forecast skin’s DAILY.WTP to the Splendid Forecast’s skin folder.

Switch your WW Forecast and Interface skin options back to Splendid.

Update your WW forecast.

I think this will give you the best of both worlds. :thumbright:


Thanks again Ed. After following the rename and copy operation, WW Daily forecast page looks good. Below is what I see and how the options are set.



If I set the Forecast Skin also to Splendid, then it is broken again.


Thank you again for your help in making WW’s Forecast display more usable to me.

– Patrick B.

If you click on the WW Option’s Skin tab’s Open Skin Location button then click on the Forecast\Splendid folder do you see the renamed DailyX.wtp file?

Ed, I was certain that I carefully followed your instructions; however, no dailyx.wtp was there to be found. I again, more carefully, followed your instructions.

Good News: With the Interface and Forecast skins set to Splendid, the page is now formatted properly.

Bad News: The wind direction icons no longer display. Why would that be?

– Patrick B.


WW has multiple Skins folder locations. The one in the Programs Files\Weather Watcher folder, which I suspect you changed originally and the one used in your Windows Profile folder which you changed the 2nd time. The confusion is why Mike added the Open Skin Location button.

One last piece of the puzzle to do. Copy the Wind folder in the Classic Forecast folder to the Splendid Forecast folder. Update the weather data and you should have a fully functioning “Weekly” forecast window. :lol: