WWL Not Refreshing Current Conditions

Upgraded to the latest version (720176) a few days ago and now WWL is not refreshing. Thinking that the station I normally use (Chicago DuPage Airport) was offline I tried selecting different weather stations with same results. I AM getting forecast data as well as alerts just not any current conditions. I re-installed the most previous version(720174) with the same results. Suggestions??? This is happening on both my Win 7x64 Pro desktop and Win10 laptop.

Update: 3:45pm CDT:

I uninstalled the program on both PCs, re-downloaded and re-installed. Both are working now.

There are a few weather stations available at that location. Here’s what I see for one of them at the moment:

Got a screenshot so I can see what you're describing?

mike, the issue was not being able to see and choose a wx station. the problem was no matter which station i chose WWL would not refresh the current conditions in the tool tip tray. all of the current condtions…temp, dew point, etc. showed N/A. this was the case on both my Win7 desktop and Win10 laptop after i installed the latest update.

as i noted in the update to my original post i solved the problem by uninstalling WWL, re-downloading and re-installing the newest version. my guess is that my initial download of the update to my desktop was corrupted. i propagate new downloads to my laptop through my network which would explain why the same problem showed up on the laptop.

thanks for replying.

Ah, yes, you did. I missed that when I read your original post via email.