WW won't update, has some issue with maps

A couple of days ago I got the message, on starting up weather watcher, that new maps had been found and I could replace my maps, combine my maps or leave them alone. I clicked replace. Since then, WW won’t update. I’ve stopped and started it and each time it asks me about the maps, and I’ve tried all the different choices with no luck. What do I do?

Try the following:

1) Exit Weather Watcher (if running).

2) Right-click the Weather Watcher shortcut on your desktop (or Start menu) and choose “Run as administrator”.

That should give Weather Watcher sufficient permissions to update your maps.

I believe run as administrator is a Vista thing. I’m using Windows XP, which appears not to have a “run as administrator” choice. I am in XP as administrator, so I shouldn’t be having permissions problems.

If Weather Watcher generated an error log, you should see a “WeatherWatcher.log” file in the files/skins location. That file might include some helpful information. See the link below if you’re not sure where the files/skins are stored.


No, it’s apparently not generating a log.

Weather Watcher or Weather Watcher Live?? I’ve receive no such message with WW.

I’m running Weather Watcher 5.6.53

hmmmmm :-k I’m running the same version and I certainly didn’t get a prompt for a map update. Something on your system changed.

I believe a difference in the date/time stamps between the files in the install folder and those in the Windows user folder trigger the prompt. Can you check the map files in those two locations?

Is this the install directory: C:\Documents and Settings[Windows Username]\Application Data\WeatherWatcher? If so, I tried deleting what appear to be the map files altogether from that directory with no effect.

Is it possible that this is just a symptom of something else? Since the map thing happened simultaneously with the weather not updating (which is my real concern; I never use the maps), perhaps the real problem is weather watcher is somehow not connecting properly and this is causing the map thing?

cherold, Weather Watcher is installed in “C:\Program Files\Weather Watcher” by default. That location might differ slightly depending on your version of Windows.

Look for a “Maps.ww2” file in the Weather Watcher program folder. If it’s there, delete it.

After deleting that file, the "map upgrade " menu still came up, only the buttons were grayed out and one said “Please wait.” After a half hour I killed it and stopped weather watcher and when I ran it again I got the “map upgrade” box again.

I don’t know what to tell you about the map update situation but the usual reason for WW not updating is either a FW or an AV stopping DL.exe or GETFILE.exe from accessing the 'net. Another possibility is a malware scan deleted one of them. Check your FW/AV/Malware scan logs for hits on these names.

That was it, something deleted Getfile (perhaps Spybot, although it doesn’t seem to have logged such an action). I reinstalled, it’s fine now. Thanks.

Thanks for the update cherold. :icon_smile: Good to hear you got the problem resolved. :thumbright: