ww.exe 100"% CPU usage

This has happened twice in the two days since I began using WW. I’m not sure if something I do triggers it; it seems perhaps it happens after I’ve been hopping around in my cities list. If I kill and restart it it goes back to normal.

This does not seem to be a known problem… Can I debug it further somehow?

When this happens, are you able to do anything in Weather Watcher, or is everything frozen?

No, the window is not frozen.

When ww.exe is using 100% of the CPU, does it look like Weather Watcher is waiting for something to happen, or does it appear that it is just sitting there idle?

If you wait for a minute or two, does the 100% CPU usage cease?

Do you have the wallpaper feature enabled in the Weather Watcher “Wallpaper” Options tab? If so, try disabling that to see if that is the cause of the problem.

It looks like it’s just sitting there.

No, it seemed it would go on as long as I let it.


Thank you for taking the time to dig in to this. I wish I could repro it consistently!

What is your Auto Update Rate set to? Setting it too fast can cause problems. I don’t remember if they occurred on slow machines or slow connections but worth checking.

15 minutes.

Same problem - 100% usage

I have the same problem with the new 5.6.18 version. My parameters seem to be set up the same as the previous poster and I had to restart the tool to get it to stop hammering the CPU. I connect via a LAN at work and Cable at home so it should have no problems connecting for a download.

marque, are you able to reproduce the problem? It would be helpful if you could tell me when it starts hammering away.

I have had it happen twice. The first time was straight after it installed. The second time I noticed it after booting my machine up. However, I have kept an eye on it each time that I booted since then and it did not repeat it. In fact, since those 2 times, this has not happened again.

Sorry - I am sure that is not what you wanted to hear.

marque, I might be off in leftfield here, but try the following to see if it causes the 100 CPU usage:

  1. Exit Weather Watcher (if open).

  2. Delete the following file:
    C:\Program Files\Weather Watcher\Fonts.ww

  3. Run Weather Watcher.

Nope. It behaved itself.


I’ve been having the same issue since upgrading to 5.6.18 too. All others parameters being the same (setup parms).

I also experienced a second issue that sometimes the skinned tooltip appears behind the current window in focus. If I click on the desktop (removing focus from said window) and then back on that window, the tooltip will appear correctly on top again.

I did a “diff” between my old Fonts.ww and the one that was created when I restarted WW and here were the differences:
[b]Compare: (<)C:\Program Files\Weather Watcher\Fonts.ww.old (2802 bytes)
with: (>)C:\Program Files\Weather Watcher\Fonts.ww (2793 bytes)

< 8514oem
< Fixedsys
< Terminal


Thanks for the great tool! It’s one of the few that I keep on using.


Sounds familiar. :wink:

The Use custom tray tooltip window location setting in the Tray Tooltip tab of the Weather Watcher Options window will allow you to work around that issue.

Thanks Mike,
I just enabled that and have great confidence that it will fix this (minor) problem.


I experienced this “100% Usage Problem” also in XP. I do know that opening the WW application by clicking on the tray icon brought the CPU usage down to zero but it went right back up to 100 after closing the application. Do you think that’s a clue?

I deleted the fonts.ww file and the problem has yet to return.


I’ve got the same problem and deleting the Fonts.ww didn’t help
and neither did closing WW. Sooo I replaced the wallpaper with a
windows default and CPU dropped to 0% from 70 to 100% usage.

Gotta say this is an MAJOR pain as I wasn’t aware WW was the cause
till I’d already tried stopping all kinds of App’s & services to no avail.
Only when I reinstall my OS did I notice the problem came back once
WW was installed an the wallpaper working as before.


The following build might resolve this issue:
Download Weather Watcher 5.6.21c

I was logging on to say same story, delete font, no help, etc.
Then say your 5.6.21C. Tried it and all seems to be ok for now.
Thanks for the revision.

Cross my fingers, this is the solution.