Wow - Many problems with 7.0.25


my system:
Windows 7 x64 German locale

Without many words - just see the screenshot:


OK, I changed the conversion setting back and forth and now the pressuere reading came down. But it’s still not correct.

After the next update it went up again to 1,094 hPa. May something wrong with the conversions?


Here’s something from another station:

Wind speed is wrong (always zero)
Barometric pressure is wrong (always the same reading, never changes)
Humidity is wrong

I don’t know, but something is very weird.

WU stations don’t show wind speed at all (I tried several). WB stations do show wind speed and both won’t show the correct barometric pressure. High and low temperatures as well as dew points are wrong for most WU stations I tested.

Here’s what I found:

  • From your first & second screenshots: The pressure is not displaying correctly because it seems that it’s using history data from another weather station. The history data conflicts with the current pressure data, so it doesn’t display properly in the main Weather Watcher Live window.

  • From your third screenshot: Shows a new weather station that was available in 7.0.25 due to some changes I made to display missing weather stations. The data you pointed out is not displaying as expected because the current conditions are coming from a different weather station.

Weather Watcher Live does not pull data directly from It’s using a separate data feed. I’m just pointing that out so you understand why the Weather Watcher Live data is not matching what you’re seeing at

I emailed my contact at WeatherUnderground to look into the data feed issues. I’ll follow up when I hear back.


thanks for looking into this matter.

Any news?

Not yet. I’ll follow up with WeatherUnderground today.