WeatherWatcher Maps failing to appear.

This is my first post ever, and I have no idea what, or how, all these options are used, and I apologize for my ignorance.

First, I really like WeatherWatcher. It has been accurate 90 to 95% of the time, for me. However, I now have a problem. Up till now, the entire program has worked very well, but as of last night, I can no longer see any maps.

I click on the map button, choose “United States,” then click on NorthEast, and choose one of the options, for example, “Precipitation Forecast.” (By the way, I’ve tried other areas of the country, as well, and other parts off the World, such as Canada, with the same results.)

What I get is: A large box, with a very brief flash of “Loading,” and then, that large box is blank, with the exception of a very small box, in the upper left-hand corner, with a little red “X” in it. No maps appear.

Am I doing something incorrectly? Should I simply reload the program, (which by the way, is Version 5.6.9)? The previous versions I used, seemed to work perfectly, certainly the “Maps” function did. I just downloaded the “Update” to 5.6.9, the day before yesterday, and had not tested the “Maps” function, up to this point.

I hope this gives you the information you need. I think I have written everything but my blood type.

Thank you.

AtyetsVolk@aol.com (Lastly: Where do I go to learn how to use the Emoticons, etc., please?)

Try right-clicking a map, choose Properties from the drop down menu, and type the URL for that map in Internet Explorer. Can you see the map then?

AtyetsVolk, if you’d like to keep SPAM at a minimum, NEVER post your email address on a webpage that everyone can access. Especially SPAMMER robots that search the web looking for email addresses to add to their email lists.

As for Emoticons, just dbl click on them and they will appear where your cursor is in the msg you’re creating.