Weather Watcher not updating weather or actrive city

I am running v .28 and have been for a while (successfully updating the versions as they arrive).

However, since end of May the temperature statistics will not update anymore. I have updated to the latest version (v .30) and still there is no change. Prior to end of May I had no problem. (XP servrice pack 3 anyone?! It forced itself onto my Pc but I have actually restored back to previous running SP2 and am avoiding SP3 now).)

When a ‘force an Update Now’ is made there is still no change. When I try to add a new active city and click Search, no search results are found despite the city in question being found and working on other pc’s I ham running (“Milan”).

Its as though it THINKS there is no internet connection.

However, when I click ‘view maps’ it does show the current weather map. (Could it really do this if there is no internet?!) And yes, of course, there IS an internet connection. (Everything else is working fine).

I see other threads with a similar problem but no one actually mentioned there active city search not working neither.

Can you help please?

Two XP SP3 pcs, one with IE 7, one with IE 6, both with WW 5.6.30x, both run WW without problem.

I suspect an AV or AS or FW update is blocking WW from reaching the 'net either directly, or indirectly like blocking access to Check their logs.

2 other XP pc’s on the same network, one running SP2, one with SP3, both with the same settings for windows firewall (ie, swirched off) and both running the SAME AV software and levels. (For all intense purposes these machine have the same configuration - these are home PC’s set up by me who do things the same way everytime I set one up). The other 2 working fine. Only the one I mentioned now doesnt work (it used to before bloody SP3 loaded itself and I restored back to the pre-SP3 intall). It may be coincidence or may be relevant. It is strange that the Weather Watcher maps use the internet and yet the search for city and weather stats update does not.

Any ideas (without being tempted into the “oh it must be the restore” as a default answer)?


The maps that work, are they from TWC or other sources?

This action is why I don’t think it’s a system problem or an Internet problem or even a WW problem. Something is blocking WW’s access to

How did you do your restore? A System Restore or a restore from a backup?

Yep – the maps just open up an Internet Explorer browser i[/i], so those should work even if an application is blocking Weather Watcher from accessing the Internet.

jimimaseye, I also have an XP machine that’s running SP3 with no problems. Did you try temporarily shutting down all security-related software?


Yes I have. I have disabled all AV and firewall software and settings and still no change.

Also, in answer to the question about the SP2 restore earlier, the system has since beenrestores using System Restore.

It really is a strange problem.

I have removed the software (uninstalled), deleted the program directory and the settings in my Home docs and Settings directoy, and then reinstalled. Despite this the Search function for the Active City does not return any results at all.

Could it be that there are some windows or windows/system32 files files being used for this program, or files are placed in these directories that have since been damamed that I can look into or remove/replace? Or anything in the registry? (Im thinking along the lines of something being missed/damaged that the install/uninstall of the program doesnt touch but yet is used)

jimimaseye, this is the only thing that does not come with the Weather Watcher installer:

Thanks Mike. Alas no difference.

Im afraid that loading the VB stuff is only ensuring the existing is already there (as I said, it used to work).

Im afraid the pure and simple answer is that Microsoft have struck again.

A shame. I really do like and use this feature alot.

Well done on your creations anyway.

Nothing is perfect, at least it works on all your SP3 machines. :thumbright: