Vista - Tray Temperature too distorted to see

Anyone else having this problem?

The tray temp looks like its black with a white background and its all blurry. I’m posting a screen shot. Any ideas?

Screen DPI set to 120?

no its set at 96 but id like to keep it that way if i can…just cause i dont like big text.

actually im assuming you were thinking 120DPI would be the problem. silly me :). regardless…i tried setting it to 120DPI and it didnt really do anything good. in fact i think it made it worse. im sad…the vista weather gadget sucks.

96 is ok. The icon is always distorted when higher DPIs are used.

Other things you can check, the background color. White, 255.255.255, causes problems. Use 254.254.254 for white. Try a different font. Not all fonts work well. I seem to recall that System Fonts work well, though my icon is using the Comic Sans MS font.

This thread may interest you:

changing the font to batang and the font color to white did the trick. im still wondering why most other fonts i choose display so poorly on this thing. regardless…i have my precious weather watcher back :).

posted at the same time. i will look into that. thanks for your help.

:icon_smile: We cross posted.

Glad to hear you got the problem resolved.

wow…we just cross-posted twice. simply amazing.

Scary even. :laughing6:

Hi -

I’m running at 120 dpi because my laptop has a WUXGA display. Is there a workaround for this issue, short of switching my fonts back to 96dpi?




The problem doesn’t occur with every font. Ed tested a few fonts that don’t cause the distortion – I use MS Sans Serif, but you could try the other fonts listed in this thread.

(edited to remove a stray tag)

Hi Jeromy -

I did see earlier in this thread that different fonts worked. I tried a few to no avail. I looked at the list you linked to and while these are definitely clearer than the others, they’re still either cut off on either side, or unreadable altogether.

Here’s a few examples - these are all at 8 point normal.

MS Serif:

Thanks for your help with this! :slight_smile:


Dan, I tried changing my dpi to the larger 120 display and I had the same problem… :-\

This problem has existed for years and across multiple versions of WW. I know of no other app that exhibits this behavior, do you?

Does it help if you don’t use a transparent background?

Actually, I have run into several apps that have this problem - GrabIt being the most notable, since this issue was brought up 2 years ago with 120DPI for font res.

Although the OS can support it, many software authors never use it, and thus put no support for them in their programs. It is more of an oversight, really, because it is one of those features of Windows that is so rarely used, if at all, by a programmer that he forgets it even exists. But hardly something that one can fault Mike on.