Tray icon support for 120 DPI

WW needs to support larger views for people with poor eye sight. This image shows a display set for 120 DPI and the impact it has on WW’s tray icon using the same font, style, size and colors as another tray icon.

http://img20.imageshack.us/img20/1930/wwiconvswpicondpilargejc7.png

Note, WW’s tray icon is the one without the border.

This is what I see (120 DPI on the top):

http://www.SingersCreations.com/Images/DPI.jpg

Interesting.

I don’t know why it’s different for you than what I see but I have seen my view on at least 3 different people’s pcs.

What font & etc do you use?

http://www.SingersCreations.com/Images/TrayIconDPIOptions.gif

Perhaps your “Make Transparent” setting is causing the problem?

Tried your font settings, tried the transparent background, tried disabling Clear Type smoothing, etc, etc, all with little difference. :sad:

It’s only WW that is effected which is strange and you not having the problem which is even stranger. Can it be tied to some external subrtn that you have and we don’t? A different version of something? An external call that’s failing for some but not you and the error not being trapped?

I’ll email you the original image in the top posting. It’s clearer than the hosted/converted picture.

EdP, I’m sure a lot of Windows settings affect the way icons are displayed in the system tray area. It would be really hard to start comparing Weather Watcher to other software because most of the software is not programmed in the same exact way. I’ll do some more testing to see if I can reproduce that result.

Thanks Mike.

This isn’t a new problem. I’ve seen this for a long time and mentioned it back in the days of the betas. WW not displaying the problem on your machine isn’t going to help. All the machines I’ve seen this on including my own are XP Home SP2 systems and current in their WUs. Some have Office 2000, some Office XP and one WordPerfect.

But the problem is unique to WW’s tray icon. If you need any more particulars or whatever let me know.

Thanks :icon_smile:

:-s ? Any progress?

I haven’t had a chance to work on this since we last talked about it.

Font problem at 120 dpi

I have also had this problem with highly blurred fonts in the tray using Weather Watcher, though the same fonts look fine in other applications. I have tried a wide variety of fonts, including bitmapped or pixel-based fonts, and TrueType. I use Windows, 1024 x 768 display, 32-bit color, 120 dpi, and standard font smoothing. The only font I found that looks even decent is FFF Forward normal at 8-point, from http://www.fontsforflash.com/. It seems to look OK because it uses only horizontal or vertical straight lines and so does not blur the curves.

Mike

Hayes re: no true type fonts allowed

I downloaded the FFF forward font - it has been properly installed - and it is not showing as an option in weatherwatcher. - and neither are ANY of my TT fonts… A fonts are all present - and all blurry.

any ideas?

Windows XP, 1G ram, competent user
Thanks
ASL4U

Re: Hayes re: no true type fonts allowed

You can force the font list to rebuild by doing the following:

  1. Shut down Weather Watcher.

  2. Delete the following file:
    C:\Program Files\Weather Watcher\Fonts.ww

  3. Start Weather Watcher.

Hayes re: new fonts

that procedure changed a few things -

  1. I can now use several (A type) fonts - that I could not use before
  2. verdana ref, ms san serif, several others look alright now - as long as I do not use the degree mark. The degree mark automatically “bolds” the numbers and pushes the left number out of view.

the results are tolerable
Thank you!
ASL4U