Tray Icon Loses Context Menu

I updated Weather Watcher to v5.6.27 today…and after switching to a weather station where there was a weather alert, the tray icon now will not open the context menu…no matter whether I right click or left click, only the Alerts window will open. This was the same problem I experienced repeatedly with Weather Watcher Live…and was why I reverted back to regular Weather Watcher.

From what I can see, the more you try to “improve” Weather Watcher, the more you are screwing it up. For me, the last good WORKING version was v5.6.25. Will you please decide which is more important…ONE version that actually works… or TWO versions that DON’T??

I’m sorry, but I’m getting pretty frustrated.

I did not see anyone else bring up this issue yet, so it kind of seems like you’re the only one experiencing it. Are you having problems accessing the system tray menus for any other software that you’re using?

Thanks for responding, Mike… I have discovered what my problem has been. My OS is Windows Vista Home Premium SP1 and your programs will only run correctly if I run them in Compatiblity Mode for Windows XP SP2.

All my other programs run just fine on Vista without using Compatibility Mode.

I don’t understand why you are writing updates and new programs that don’t appear to be compatible with Vista SP1… but I guess I’ll be happy to use them as long as I can get them to work.


Works fine on my Vista.

Hmm… I can’t figure this out. I thought it was working fine in Compatibility Mode, but it’s doing the same thing now. For some reason when I right click on the tray icon, it opens up the Alerts window and then I have no tray context window after that. The only way to get to the main WW window is to launch it from the Desktop icon. Even after that, I still have no tray icon context menu. This only happens AFTER there is a weather alert issued.

Any suggestions now?

I’ve uninstalled, cleaned out registry, reinstalled… and it still doesn’t work right.


biggles150, are you using Vista SP1?

Something having to do with the way Alerts are handled must have changed after v5.6.25.

No, I haven’t been offered SP1 yet, MS says not to install yet until you are notified, I think they may be having problems with it as it’s been withdrawn from Windows Update for now.

That’s very odd… I was offered Vista SP1 when it was released through Windows Update on March 18, 2008, it installed just fine and runs just fine. I do know that you have to have all your computer’s drivers compatible and up-to-date, otherwise Microsoft may never offer it to you. Anyway, unless software writers are testing their products using Vista SP1, their programs might not work correctly. I think that is the problem I’m experiencing with Weather Watcher and Weather Watcher Live. I really don’t know whether Mike is testing his products with Vista SP1 or not. Kinda strange that a really old weather program like Weather Exchange which is associated with WeatherUnderground works just fine for me though.

My main development PC has Windows Vista SP1 on it. I’ve been using SP1 since it was first released.

Did you try deleting your WWL registry key?

HKEY_CURRENT_USER\Software\VB and VBA Program Settings\Weather Watcher Live

Thanks for the response, Mike. I checked to see if I had any such registry entries, but since I totally uninstalled both Weather Watcher and Weather Watcher Live, I no longer have any references to either program anywhere in my registry. I really liked your programs, but I’ll have to wait until one or the other of them is truly FINAL, FINAL, FINAL and truly WORKING, WORKING, WORKING with Vista SP1 before I’ll put it back on my machine to see if it works. Sorry, but I just got tired of hassling with them.


What did you use to do your uninstall? WW’s uninstall only removes the files that it adds to the hd. It doesn’t remove any of the files or Registry entries that WW’s use creates.

EdP… I used WW’s uninstaller, then deleted any remaining folders and files showing in Windows Explorer under Users and Programs, etc… then I used CCleaner to eliminate any other possible leftover registry entries. All references to WW have been cleaned off my system.

Just for the record, I never had that problem in either WW or WWL in both Vista ultimate 32bit w/ SP1 and Vista Ultimate 64bit w/ SP1.

I have had other problems, but never a missing context menu.