The file 'Current' cannot be opened.

Hi, I have installed .NET Compact Framework 2.0, followed by Weather Watcher 1.0.5. However, when Updating the weather data, after 'Downloading weather data…" and “Processing weather data…”, an alert came up that says:

The file ‘Current’ cannot be opened. Either it is not signed with a trusted certificate, or one of its components cannot be found. You might need to reinstall or restore this file.

When I click on the other tabs, say ‘Hourly’, it’ll show the same message with ‘Hourly’ instead of ‘Current’.

I tried uninstalling Weather Watcher and reinstalling, but I’m still getting the same error. Can you please help me with this?

Sylar, from what I found out on Google, it seems this is a Windows Mobile related issue.

Try the following:

1) If Weather Watcher Mobile is installed on a memory card, then try installing it in the main memory of your mobile device.

2) Try making the following registry changes (see 6th post):

3) Check out the many links at the following Google search:

I have the same problem.
I have tried modifying the Registry and to run the application with /R
Nothing happened.
Same error.
Can somebody help?
I’m running JasJam with WM6.

Your help will be appreciated.


Don’t worry, I got it.
The problem was I set up Opera as default browser.
Now with IE everything is fine.

Thanks again.

I am getting this same error. I am not comfortable with editing the registry. Is there anything else I can do? I have tried uninstalling and reinstalling and moving to main memory instead of storage card. I am using the most updated version. It used to work and then suddenly stopped working.

huggingtigger, is Opera your default web browser? If so, it looks like the issue can be resolved by setting IE as your default web browser.

Thank you for the fast response.

Opera mini is my default. However, I have been using opera mini as my default for awhile, and this problem only started recently. Also, even after changing back to IE as the default browser and performing a soft reset, I still get the same error.

Do you have any other suggestions I might try?

huggingtigger, I’m not able to reproduce this problem, so I’ve never had the chance to attempt to resolve it. A lot of related information can be found at the following link:

I’ve checked out those links, but nothing there really seems applicable to my case.