Temp below zero??

Mike I’m having an issue with the new addition of temp below zero. I’ve got it set up to show black text in a white background. For some reason the background will not change to white. It remains black and the text remains white. In the screenshot it shows a red background for the weather alert. If I shut off the alert it will show white text on black background which is the norm. I would like this so as not to have to show the minus sign. Attached is my screenshot.
http://s10.postimage.org/ckar4u82d/Untitled.jpg

Re: Temp below freezing??

Here’s a screenshot showing what happens when I shut the alert off. Neither the type or the background change occurs that I have in my options for temperature below zero. Everything works for the alert change but not for the below zero change.
http://s12.postimage.org/4rj7xf3sp/Untitled.jpg

It looks like this issue only occurs when a severe alert is available. The following build should resolve this issue:

https://www.box.com/s/9iijib6ok6jv1ef39hdj

Installed the new build and the problem is the same as it was before. The alert is still in effect. I turned off the alert function and the reversion was the same as yesterdays screenshot. Just can’t get the font and color to change for temp below zero. I’m using the minus sign now to compensate as it is still below zero. Also almost every time the temp is below zero we are also in an alert state. This one expires at 10 this morning (8:30 now) and we’ll see if it does then if the temp is still below zero.

The alert is over and nothing changes for me. Can’t seem to get the below zero feature to change font or background. My screen shot shows the options with only below zero checked.
http://s13.postimage.org/il1god8tv/Untitled.jpg

Here’s what I see using the same build:

http://s14.postimage.org/6f4v4cyl9/Alaska.jpg

After some more searching through the code, I found the change I made in this build really didn’t change anything.

Please export your Weather Watcher Live registry settings and email them to me at Mike@SingersCreations.com. That’ll allow me to try reproducing this issue using your exact settings.

1) Click the Windows Start button, choose “Run…”, and enter “regedit” in the run window.

2) Navigate to the following registry key in the left menu:

HKEY_CURRENT_USER\Software\VB and VBA Program Settings\Weather Watcher Live

3) Right-click on the “Weather Watcher Live” key, choose “Export”, enter a file name, and click the “Save” button.

On the way to you Mike. Hope I did it right?

Yes – thanks! The following build will resolve this issue:

https://www.box.com/s/x9rtoloq78mb0hjn7koq

Downloaded and will install but it will be a while before I can see if it works as it is up to 18 right now and no sub zero for a few days in sight. But I will let you know when I get a chance to put it through the test. Thanks for you help. On a side note from your screenshot I noticed your systray icon font and decided to give it a try. Kind of like it right now and want to see if it will show the minus sign with two wider digits like a two and a zero? But once this color change works for me, no need for the minus sign. Thanks again :icon_smile:

I’d also like to get a clarification on one thing. With the alert background and font change checked, will that take precedence over the below zero color and font change? If so I might just turn off the alert change over the winter months and opt for the below zero change. I’d still get alert popups and sounds giving me warnings so I wouldn’t lose much there but would gain the correct sub zero temperature appearance. It looks like the next below zero day is the 23rd. so it will be a while before I can give it a good test. “Merry Christmas” to all!

Yes. The colors are set as soon as the first condition is met – starting from the top.

Good news Mike, didn’t have to wait long to test the new build. Just noticed the feels like is minus 5 so I switched my option to show the feels like temperature and perfect. The background and font changed to reflect the below zero reading. For whatever reason what didn’t work before now works perfectly. Thanks again for all your help in solving this issue for me. :icon_smile: