Sygate and latest Weather Watcher

Hey, ever since I updated to the latest Weather Watcher, Sygate won’t let it update the weather. It just keeps popping up the “do you want to allow this program to connect to the internet.” Any ideas on why thi just started occurring? I even checked my firewall settings to make sure that dl.exe was checked for Allow, it is.

Today I loaded version 5.4c and got the same problem with Sygate as HASMTERKILL reported. I uninstalled and switched back to V5.4b, no problems.
Any idea what is causing this?


I downloaded the ver 5.4c and sygate keeps asking if I want to allow Weather Watcher to access the internet. I check to remember my reply, and answer “Yes” and then it asks the same question again.

I then deleted Weather Watcher and installed the full version, but I get the same query continually. I have had to turn off Weather Watcher.

Is there some place I can get Version 5.4b ? It worked O.K. ?


Look at the posts above… it looks like someone found a work-around. I’ll have to see if I can download Sygate and try this out myself. In the meantime, just hang in there.

There is a new beta version of Sygate released today…

Sygate Personal Firewall Free 5.5 Build 2577

Get it at

NOTE!! It does NOT fix the problem of weather updates–but workaround posted here does work! Reverting back to version 54b eliminates all problems. Weather update works just peachy.


I installed the newest version of Sygate (the free one) and it worked OK with WW 5.4c. Someone told me today that he had to reinstall Sygate to fix the problem.