Server Not Found Again


I’m running 5.6.11 which I installed yesterday. It worked ok then but this morning I kept getting “Server Not Found” on every update.

To fix this I removed the registry for WW and left it recreate it. Then it works again.

The quesiton is, why does this work and what changes did this make that couldn’t be made invisibly from within the program?

Hey Hoover.

Can you describe what’s unique about your system that causes this to occur? What OS are you running, what firewall, what antivirus, what antispyware, what system changes safe guards, ie Windows Defender?

Do you reboot after upgrading? Sign off and back on?

Did you perchance export the Register key that you removed before you removed it? If so you could then export the current WW section and we could compare them.

Nice to know you found a somewhat straight forward solution to the problem. I assume that you remove the WW Registry key with WW shutdown, but doesn’t that cause you to loose all your WW settings and thus you have to reconfigure everything when WW restarts?

Hi Ed,

I’m running XP SP2 on a 2.53Mhz Pentium 5. Outpost Firewall and AVG anti-virus.

I have both the before and after reg information if you want it but what I saw from it didn’t tell me anything about servers. Maybe you’d be able to spot the problem.

The curious thing was that after I removed the registry tree, the next time I ran WW, Outpost reacted by offering to create rule entries. So… what does this mean? It pretty much means that WW wasn’t getting past the step of actually hitting the internet for the information, else the firewall would have asked for permission. I don’t use MS builtin firewall by the way.

Yes when I do this I have to recreate my settings. I’m so aware of what they are it takes me about 30 seconds to do it. Fortunately, all my location entries are not in the registry so other than hitting a bunch of check boxes.

I have a laptop which has WW on it but it isn’t on very much. I don’t run Outpost on that so it is fair to consider Outpost to be a suspect.

I think it means you have found the source of the problem. :lol:

I don’t use Outpost so I can’t help you too much but I use Zone Alarm on one pc and Sygate on another and whenever WW, or any program including AVG, gets updated and then tries to access the 'net the firewall flags the access with a prompt that I get to reply to. It seems that Outpost does the same but for some reason isn’t popping up when WW gets updated. It could be an Outpost setting, an Outpost bug, or something totally different. :???:

See if Outpost keeps a log of it’s activity see if it’s log shows any rejects for DL.exe or WW.exe after you upgraded WW to 5.6.11. If not, see if it has a Quarantine folder and if either WW.exe or DL.exe is in it.


I’m still suspecting Outpost as well. But it wasn’t logging any block so that is what has me still questioning it.

If this happens again, I will delete the current rule set for WW and DL. What is probably happening is that since the executable changed it is no longer allowed internet access. This is actually a good thing. However, it should say as much and allow a renewal of permissions.

I’m not 100 percent sure this is it, though. The question is why did a deleteion of the registry make any difference then?

  1. If this happens again and
  2. I have to delete the registry as a final solution

I will let you know!

:iconbiggrin: Looking forward to it. :icon_smile:


I am brand new to this forum but I have been using Weather Watcher for many years. This is the first time I have a problem with it. I also get “Server not found!” message. I think it has nothing to do with firewall. I get this error either if I switch the firewall on or off (I use Kerio Personal Firewall). I also tried to delete \HKCU\Software\VB and VBA Program Settings\Weather Watcher registry branch. On next start Weather Watcher wants me to set it up but after selecting a city I get the error again.

Is it possible to download older versions? I would like to try returning to the previous version. It might be interesting to see if it helps.


I have just tried to turn on my notebook where I have 5.6.9 version, different Windows, different firewall, … It also does not work, I get the same error: Server not found! Seems like a problem on the server or on the network.

I don’t think this will fix the problem… the downloading code hasn’t changed throughout the past 30 releases or so.

Which version do you want to try?

After trying 5.6.9 on my notebook I also do not think it will help. The fact that two different versions (5.6.11 and 5.6.9) stopped working at the same time on two different machines (Win2K vs. WinXP, Kerio vs. standard WinXP firewall, Avast vs. Symantec antivirus etc.) would lead me to a conclusion that the problem is on server or network side. But reading that other people made it working by cleaning registry does not support this deduction. Well, where could be the problem? :roll:

I can’t say conclusively, but WW is still suspect. I won’t be able to say so for sure until it happens again (I do hope it doesn’t) and I can delete the rule set from the firewall (in my case Outpost).

It has happened in past versions so this isn’t new.

The other thing that has me wondering is that it worked for a time after the new install then it stopped some time later. This makes me think its a gremlin (a bug that seems to show up at a odd times, often a memory overwrite problem).

What I think is happening is that when we wipe the registry, WW takes a different program path and so we avoid the bug simply because it is executing different code. I will say it again, I don’t believe, when we are getting the server not found error that it is even hitting the internet in the first place. And again, I can’t prove it but will experiment with that idea if/when the next time that happens.

I agree. Can you access directly using IE?

Next time read this FAQ also. :icon_smile:

Unless you’re running Win 98 memory overwrite is unlikely. However, as for WW working then stopping, do you have any daily AV runs scheduled? Any other apps that auto run daily or at shutdown? Defrag’s? They could be triggering something that interferes with the new WW files.

Wow, interesting. I can’t access this web from my browser. If I turn off my firewall and antivirus, I still cannot access it. I have no idea, why I cannot get to this URL.

Any idea what else could be blocking me from accessing specific web sites?

Some antispyware sw do that. Or if you’re at work the network’s admins may have blocked access to it.

Good hint, but unfortunatelly I still cannot get Weather Watcher working. I have my desktop located at home and connected to a DSL provider. If I try company notebook, I get the same results, even there is different software installed (Windows version, antivirus, firewall), I use Spybot Search & Destroy on desktop and Microsoft Antispyware on notebook. I get the same results, the software stopped working at the same time on both computers.

Well, I’m just performing an experiment. I’ve just connected to company network from notebook through a VPN, so I bypass my home internet provider.

Wow! It works! :cool: So it seams having nothing to do with software on my computers. It is a problem with my internet provider - they just block access to some pages (I cannot understand what’s wrong on or they just have a mess in their DNS.

I am gonna contact my ISP to get know what is going on. Thank you all for patience. :oops: Hope it may help to somebody else or at least the list of possible problems can just be extended with a new option.


Interesting. :???: Please report back as to what your ISP says is the reason for blocking :icon_smile:


I am back again. I was two weeks on vacation. Meanwhile Weather Watcher has started working again… My ISP responded that they block no addresses but I should have try to contact the server ( admin to ask if they block any “public range addresses” (so called bogon filtering).

However there is nothing to do because it currently works. Maybe it was some temporary problem in DNS or server configuration, who knows.

Anyway, thaks to all of you for your tips and help.


Thanks for the update tengler. It sounds like a happy ending. :icon_smile:

It’s possible that switched to an alternate alterate IP address and your machine didn’t update its DNS buffer which in turn timed out while you were gone and reloaded when you got back.

Should this ever happen again, and hopefully for you it won’t, but if someone else runs into it, there is an XP command you can try:

ipconfig /flushdns

Execute it from a Command prompt window. (Run > cmd /k )

Wow, sounded like someone got some of their problems kinda fixed :eek: I must say, though, this behaviour REALLY made me wonder:

Apparently my computer works pretty much different from some of the other computers out there; mine has you install programs on given locations, these programs may or may not write a small amount of information to the system registry. And unless another version of the program is installed, it doesn’t change either it’s location or the code that is executed…

Further more, if I remember correctly, the “server not found” error is an online error, returned by the DNS upon reaching a time out without finding any other servers that know of the requested server - so to get this without “even hitting the internet in the first place” would also prove the point that this is a somewhat mutated computer…

I’m not saying it’s not possible, just that it’s not very likely…