Resizing main window

The latest version of WW has some good improvements, but I now find that I can’t make the main window SMALL enough in height so the columns at the bottom are much too long and thus are half empty. :roll:
Can this be fixed?

This would be due to the new feature in the Splendid Interface skin.

The following lines are now in the Splendid skin.ini file typically located @ C:\Program Files\Weather Watcher\Skins\Interface\Splendid

MinWidth=9250 MinHeight=7900
The minimum height of the Splendid Interface is now 7900. I’m not sure what units Mike is using, it’s obviously not pixels.

The short answer is this, either you can modify the skin.ini file or you can download and use a different Interface Skin from these forums.

http://www.singerscreations.com/Forum/v … m.php?f=23

If you modify the skin.ini file, you should make a copy of the directory and call it something like “MySplendid” to prevent your modifications fom being overwritten by a future release.

Xtrafred, can you post and/or e-mail me a screenshot? Mike@SingersCreations.com

Thanx a lot! :iconbiggrin:
I changed the values until I got the window size that I wanted! :thumbup:

Deleting those values will solve the problem too. I’m still wondering what the main window looked like :-k

I also found both the MinWidth/Height values in the Splendid interface skin.ini too big; I commented them out and got the appearance I wanted.

Before, my main window looked like this:
http://img143.imageshack.us/img143/249/wwqn5.jpg

The appearance I wanted is this:
http://img148.imageshack.us/img148/9518/ww2qz7.jpg

I also noticed a glitch of some sort: I found I could resize the window in any other skin (since only Splendid’s skin.ini has MinHeight/Width values) but if I did so and then switched back to Splendid the window size went wacky:
http://img148.imageshack.us/img148/2765/ww3vc2.jpg

MKairys, what is your resolution set to?

1600 X 1200, 120 DPI

The issue was being caused by the DPI setting. Here’s a fix:
Download Weather Watcher 5.6.19a

Usually is :slight_smile:

Perfect, thanks!

Well 19a doesn’t fix it for me and I have standard DPI. Switching from the Splendid interface to other skins, resizing the window and then back to Splendid yields the same enlarged results MKairys was seeing.

And you can’t resize the window back to normal using the Splendid interface.

Hmm… I cannot reproduce that issue with 5.6.19a. Are you the only one? :-k

Well returning to the Splendid interface now, the width is normal, the width is adjustable and the bottom is so far off my screen I can’t access it. And it now impacts all the other interfaces!! Their bottoms are all off my screen and can not be brought back either.

The randomness of the problem implies memory being corrupted.

EdP, try the following:

  1. Close Weather Watcher.

  2. Delete the following registry key:
    HKEY_CURRENT_USER\Software\VB and VBA Program Settings\Weather Watcher\Misc

  3. Run Weather Watcher.

Thanks Mike but I got past the problem by switching to the Tronnix interface and noticing it’s bottom was behind the Taskbar. I set the Taskbar to be Hidden and was then able to pull the bottom of the WW window up.

I also considered creating a dummy interface with the new size options set to create a small WW window which I could then resize but didn’t need to.

Looking forward to 19B. :razz:

Another problem is that WW is n o longer restoring its saved width and height on startup. I can see that it is correctly saving the values in the registry on shutdown (IfaceWidth/Height) but apears to ignore them on startup.

Don’t mean to bug you, but I hope this got on your list…

Which version of Weather Watcher do you have? Version 5.6.20c is loading properly on my computer.

Are you using any special resolution, etc. settings that aren’t in a standard Windows setup?

Sorry, you’re right, version 20 seems to initialize its size correctly.

I didn’t actually realize 20 was there, because I was waiting for WW itself to announce an update, and it seemed to think 19 was the latest available. And when I did go to download, it was 20A that was available, not 20C :???:

Anyway, thanks. It looks just Splendid! :icon_smile:

Getting back to the original topic of this thread… I removed the “MinWidth” and “MinHeight” settings from the Splendid interface skin in the latest Weather Watcher release.