proxy server

I can’t get WW to work thru a proxy. Is there a way to do it?

Since no one has responded, I guess it’s not supported.

Mike - do you have any plans to support proxy servers in the future?

Dave – You shouldn’t need any special setting to use a proxy server. I know of people out there that are using Weather Watcher with a proxy server now. Do you have the latest version (5.0.20)?

I just downloaded the latest version and tried it again. It runs and says “n/a” in the tray. I open the options and click on “Find your city” – the dialog box comes up, I enter my city, and it just sits there “processing…”.

If I put my zipcode in for my city, it never gets any weather, it just says “n/a” in the tray. I can click on “Update Weather” on the menu, and it stays “n/a”.

Maybe something else is wrong, but it’s acting like it can’t get to the net (and I know we use a proxy server here).

When I use other tools, like jedit (and even weatherbug) they have to know about the proxy server in order to do anything on the net.

Is there something else I should check?

Dave – Nope, it sounds like you are doing everything OK. I would gladly work on a proxy server connection if you can give me access to your proxy server. I don’t use a proxy server, so there would be no way for me to test something like this out. If you’re interested, please e-mail me at Mike@SingersCreations.com.

Proxy servers shouldn’t cause any problems. I’ve spoken to a few people already who are successfully using proxy servers with Weather Watcher.

I had the same problem with applications that quit working from my system tray because they could not access the internet. I am hesitant to share a solution given to me that worked because it involves messing with the registry. It may only work if you are on Win98 and using a DSL connection like myself. BE SURE AND BACK-UP YOUR REGISTRY BEFORE YOU ATTEMPT THIS!!

Copy the bold to Notepad, and save as Loadsens.reg (save as ‘all files’)
Doubleclick Loadsens.reg, and answer ‘yes’ when asked to add its contents to the Registry.
That will make the change for you without the need of actually editing the Registry manually.

[b]REGEDIT4

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\WebCheck]
“LoadSens”=“no”
“LoadLCE”=“no”[/b]

Just doubleclick that Regfile (whereever you save it) and reboot.I would look at the registry string above and see what values are listed in yours before you attempt to do this. Again, this may only work for Win98 with a DSL connection. Be careful, unless you are comfortable with what you are doing!! Good-Luck!

Rob Rothe

Thanks, Rob!

If that doesn’t work, you can undo those changes by following the same instructions above, but using this text instead:

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\WebCheck]
“LoadSens”=“auto”
“LoadLCE”=“auto”