Please help - "Apply" button grayed out.

Hello everyone, I’m having problems getting weather watcher going. I had to factory restore my laptop, there was no virus or malware, just some odd problem with installing programs and windows update, but it was running weather watcher 5.6.41 well with no problems. Anyway, after the restore I downloaded the newest release of weather watcher, and could not set any options because the “apply” is grayed out in options. I tried to go back to 5.6.4 and am getting the same problem with that version as well. I am running Vista and have to use internet connection sharing with a mobile wireless connection but there are no proxies. Has anyone run into the grayed out “apply” button? Is there something I need yet to update in my PC or router? I’ve done all the widows updates, except for service pack 2, I have enabled weather watcher in the vista firewall exceptions. I have tried reinstalling and uninstalling weather watcher as well.

The “Apply” button will always be disabled when you open the Weather Watcher Options window. As soon as you change any of the settings, the “Apply” button should be enabled. FYI, clicking the “OK” button will automatically apply your changes.

Are you saying that the “Apply” button is not enabled after making changes? If so, do your changes save properly if you click the “OK” button?

Yes, I put in the zip code, and go on to other tabs - adding something to the ignore list etc and toggling other changes, hitting OK each time, and they don’t stay, the “apply” button also stays grayed out the whole time. Then when I start weather watcher again it says I need to specify a city, but I can see my zip code in the main window. It is obviously something wrong from my end since 5641 used to work on this machine. My zip code is showing up but everything says NA with red boxes and it tells me “before you can use you need to specify a city” or something to that effect.

I do not have an antivirus running constantly but I use Avast, I have spybot S&D and Lavasoft’s adaware, but these programs have never conflicted before. I just have basic windows firewall, I am wirelessly connected through a router that’s switched for ICS. This has never been an issue with weather watcher either. Perhaps this is a java, shockwave, flash error. I’ll double check on those later today and poke at it some more. Maybe I can drag the set files from another PC and overwrite it in my laptop. I have the barest of stuff running in the system tray since my connection is slow and I share it with the family, so nothing was running during the installation.

I do have trouble loading sometimes, late last year for weeks I couldn’t until they changed their code. Only the top bar on their web pages would load, now if it happens a simple refresh does it. I couldn’t load their sites on Vista or XP. But weather watcher would load so that was nice to bypass the glitch.

Thank you Mike, I’m missing weather watcher, especially now with raging monsoon storms blowing through AZ, temps expected to be well above 110 F. this week. It’s nice to know when wrath of god is about to descend. :roll:

Does the pc have multiple user accounts on it and are you signed on with one that has admin rights?

Hi Ed, yep I did that too and toggled between Vista Basic and Aero. I notice that SysFader is loading with both 5641 and the latest version, so I tried to toggle between the clear font and standard font, but that didn’t work either. weather watcher also wasn’t completely closing when it was closed, it looked shut down but it remained in the taskmanager process list and I manually closed it. When I uninstall the versions, my zip code is still showing up on the main page when I install a new version. I deleted cookies etc. and the folder in program files when I uninstalled, but the zip still shows up in the new install. There must be somewhere that it stays, I looked in the registry and couldn’t find anything. I deleted Java temp files, reinstalled java, flash and shockwave. I went over iexplorer 8’s settings to see if something was in conflict in those settings, but everything is default. I do have google toolbar going, but I had that before and it didn’t interfer. The apply radio button stays grayed out and hitting ok does not save changes.

Anyway, this is Vista’s fault, I hate Vista. If it weren’t for all the drivers and all that the laptop needs I’d wipe the hard drive and install XP. On my XP desktop there is weather watcher 5625 so I copied that program folder and pasted it into the Vista laptops weather watcher folder and overwrote all the files. Then it loaded up and had pictures etc. (yay!) but asked me to specify a city so I thought “Oh no!”, but the apply button and OK button are working, so problem is solved :cool: except I have no idea why it was acting so odd, so I can’t help much.

I’m going to try to update it to the new version, if it can’t I’ll just paste the 5625 folder back in. :icon_smile:

Interesting that 5625 works if 5651 doesn’t.

WW settings default to storing in the Registry at:
HKCU\Software\VB and VBA Program Settings\Weather Watcher

There is an option for having WW store it’s settings in the install folder. Start WW using the -id parm; like this ww.exe -id .

Deleting the Registry entries before reinstalling 5651 may help, if not try starting it with the -id parm and see what happens.

Hi Ed, I tried to update the Frankensteined 5641/ 5625 folder and that didn’t work, then I just tried to install 5625 and it wouldn’t work, so uninstalled it, then installed 5641 again and it wouldn’t work, so pasted the 5625 folder back into 5641 and it didn’t work, but then when I clicked on the text in “Automatically retrieve forecasts when a new city is added” button that’s underneath the Active City tab, for some reason Apply popped out and I got it working again. Unticking it made Apply gray out, hitting OK didn’t work before or after that either.

I’ve uninstalled it now and there is no registry entries. I used CCleaner to clean everything and look for errors. (CCleaner has always played nice with weather watcher in the past)

Trying the 5651 again - the -id parm? :oops: I’m not sure what that means. I would put that in the desktop icon window properties where it says Target File? It says this now, if I try to put -id inside the quotes, an error pops up that it doesn’t exist.

“C:\Program Files\Weather Watcher\ww.exe” -id

Nope, no luck with that, if I did it right, Apply stays grayed out and it won’t let my zip code or city stick in options.

I exported the reg file and see the zip code entries are different from the other keys, in options, it doesn’t have the final quote at the end of the zip code but lists it twice (I put X’s instead of the actual zip)

“CityCode”=“853xx (then there is a long space) 853xx”
“LastCombo1”=“853xx (then there is a long space) 853xx”

Is that normal? I deleted the zip codes in reg keys but it didn’t help.

The pictures on the main application window are gone now, it’s totally blank, except the black top border.

… well, I can use the Frankensteined version, that’s no problem, it’s functional. My laptop is going out of state for a month with my son so I won’t be able to tinker with it. I’m going to try to compare registry entries with 5651 and the Frankensteined version to see if that’s it. :icon_smile:

  • EDIT - Yes, there are a lot more keys and string values in the registry with the older file version, I think it’s just not installing right, could be a vista update interfering that I didn’t have before, the CityCode and LastCombo1 data is different with the older files.

Well my Registry entries don’t look anything like yours. Granted I’m running XP not Vista but I don’t think that wouldn’t impact the app’s naming conventions.

I do not have a LastCombo1 and for CityCode I see:

“City”=“Fair Haven, NY”

Oh, I think I see what you’re looking at. You’re looking at the Options key. Under mine I have:

“CityCode”=“12343 12343”
“LastCombo1”=“12343 12343”

I think the Options key is for the ToolTray Options but I could be mistaken.

Anyways, my Reg data does match yours so I don’t think that’s the problem.

Not sure what’s going on with your situation. It could be the machine’s firewall stopping WW from accessing the 'net to validate the zip code entry.