No Weather Map showing in NOW section

The weather map is not showing in the NOW section.

The following information is provided:

Windows XP
Mozilla Firefox
WW Version 7.2.203
Flash - Enabled
Java - Enabled.

This has been an ongoing problem for about the last 10 versions.

I have noticed the same issue. This was happening a few versions back.

@wetlook, are you also running Windows XP?

I have Win 7 64bit.
Here is a screen shot I just took.

Just installed 7.2.208 and still no map showing in NOW section.

Same here. When installing the latest version there was an error message about failure to rename the file ‘wwradar’.

I forgot to mention i tried running as administrator with the same result.

The weather map is still not showing in the NOW section even after installing the latest version.

The following information is provided:

Windows XP
Mozilla Firefox
WW Version 7.2.210
Flash - Enabled
Java - Enabled.

That makes sense. No changes were made for Windows XP in the latest version.

In addition to Windows XP no longer being supported by Microsoft, there are likely other undiscovered (by me) issues that are preventing the map from working in Windows XP. One issue is that Windows XP is not able to run the version of the .NET framework that Weather Watcher is using in version 7.2.210. I downgraded the .NET framework to 4.0 (the latest version Windows XP can run) in version 7.2.211. You’ll also need to have .NET framework 4.0 installed (download it here if needed).

Mike - I’m using Windows 10 version 1903

Just installed 7.2.212 and it fixed the issue with no map showing in the Now section. Thank you for fixing that!
By the way, the Latest Changes area shows 7.2.210 as the most recent version.

Same issue as before.

Win 7 Pro 64bit.

Here is the WWL I launched just now. Still having problem with no Weather Map showing in NOW section.

NO weather map…blank!..……will not load

Have any of you tried upgrading to version 7.2.213?

I have, and it works just fine.

Yes 7.2.213 is working fine for me now.
Thanks Mark for your help!