New Auto Updater Updated but needed to be manually restarted

This applies to Windows 10x64 Pro Build 13682.175 V1903 will all software update-to-date. WWL was version 7.2.188. Here is the chain of events:

  1. Started up PC for the day.
  2. On reboot and WWL 7.2.188 was running for a few minutes, I did a right click on the WWL icon in the notification tray and “Check for New Version”.
  3. WWL 7.2.188 issued a message that 7.2.189 was available to install. I clicked on OK.
  4. The new installer killed WWL 7.2.188 and proceeded to install 7.2.189.
  5. The new WWL icon appeared on the desktop.
  6. The new updater installed 7.2.189 but then did not restart WWL to finish the installation. I waited a couple of minutes for the installation to continue.
  7. I manually restarted WWL.
  8. The “This may take a few minutes” and the change log appeared.
  9. The installation completed successfully.
  10. I confirmed that 7.2.189 is the current version.

Fluke or minor bug in new updater procedure? …which BTW is an awesome enhancement!

I tried this on my Dell XPS 15 (9575) 2in1 laptop and the exact same failure occurred.

It’s an issue with the command line parameters I’m currently passing to the new installer when Weather Watcher downloads and runs it. It’ll be corrected in the next Weather Watcher release.

Thank @17blue17 for suggesting it :wink:

JFI, Going from 189 to 191 has the same issue.

I was working on this yesterday since I ran into the same issue when installing 191. It was a tough issue to track down, but I believe the problem was really that the installer did not have permission to restart Weather Watcher. The issue should be resolved when upgrading from 191.

Updating from 191 to 192 worked perfectly. Thanks again for the enhancement!

1 Like