Map Upgrade Assistant screen

Running WWL 7.1.35 Win7 64bit. When I boot up the “Map Upgrade Assistant” always prompts for input to change or keep maps as is. Most curious. Is there some option I’ve failed to set? THX –

Try the following:

1) Right-click the Weather Watcher Live system tray icon and choose Exit to shut it down.

2) Right-click the Weather Watcher Live shortcut on your desktop (or in your Windows Start menu) and choose Run as administrator.

That should give Weather Watcher Live the proper permissions to update your map files. You should only have to do this one time.

I did as instructed but no change. Just for the heck of it I uninstalled WWL and re-installed too and did the “administrator” suggestion. I’ll try it again.

After reinstalling Weather Watcher Live, you will always see this prompt on the first run. You should not see it again if you restart Weather Watcher Live though.

If you’re not able to resolve this issue by reinstalling, then please check if Weather Watcher Live has created a log file. If so, you’ll find it in one of the following locations:

C:\Users[Windows Username]\AppData\Roaming\WeatherWatcherLive\WeatherWatcherLive.log

-OR-

C:\Documents and Settings[Windows Username]\Application Data\WeatherWatcherLive\WeatherWatcherLive.log

If found, please email it to me at Mike@SingersCreations.com.

Somethings wrong Mike, mine started doing the same thing. The change map prompt comes on every time I start WWL, never did that before. Kind of irritating.

Looked at your suggested fixes, nothing works. Also looked for a log, no log. It happens every time one shuts down WWL and then restart it. A response is required to the map question before the program will open. In the past that screen only opened the first time after a program upgrade, now it’s forever on every single start.

Chunker, try installing version 7.1.37 from www.SingersCreations.com. That should resolve this issue.

Upgraded and the same problem persists. After upgrading did a pc restart and the first time I opened WWL the map screen appeared. Opted to keep maps as is and the program started. Let it run for a bit them closed it. On starting it again, the map screen comes on again with every exit and start.

Chunker, what is this setting set to in the Windows registry?

HKEY_CURRENT_USER\Software\VB and VBA Program Settings\Weather Watcher Live\General\NeedToUpgradeMaps

Also, did you verify that you have version 7.1.37 installed? I just want to check that the new version installed as expected.

Yes, I verified and I have 7.1.37 installed. I also checked that reg key and it is set to “false”.

Chunker, when you choose to keep your maps as-is, does the date modified time stamp change on the following file?

C:\Users[Windows Username]\AppData\Roaming\WeatherWatcherLive[b]Maps.ww[/b]

-OR-

C:\Documents and Settings[Windows Username]\Application Data\WeatherWatcherLive[b]Maps.ww[/b]

The above file locations are also assuming that you do not have the “Store user files in the Weather Watcher Live program folder” box checked in the “General” section of the Weather Watcher Live Options window. You should uncheck that nox if it’s checked.

Mike something crazy is going on. I was just giving my wife a demonstration on what is happening and wouldn’t you know it started working? Never touched or changed anything, just checked your first two suggestions, program and reg key. Now I guess I have to digest what your last response is, that might take me a while. But right now, it seems to be working as it should. Since I upgraded I’ve done about 6 or 7 program exits and starts with the map screen always asking for a prompt. Now it doesn’t appear to be happening? Kind of scared to touch anything now that it appears to be working.

Checked those two items for you. No, I don’t have a checkmark in that general options box. Also I went to the Maps.ww and it shows today’s date. Kind of scratching my head???

That registry setting was not being reset to “False” in the previous build. I believe that is what caused that problem for you. The only other thing that would trigger the prompt is if the last modified date was not being updated on that file. I’m not sure why it took two runs to update your maps after installing the new build. You should only see that prompt once after a new install.

I see at the beginning of this topic somebody else was having the very same problem. Will keep an eye on it from now on. Thanks!

Chunker, that was the issue I fixed in the build this morning. I think all is working well again.