Map Upgrade Assistant crash

OS: Vista Ultimate 64 bit

I can’t run the program becouse, after install, it always crash at first run during Map Upgrade Assistant.

The message is:

weather watcher run-time error -2147319779 (8002801d) automation error library not registered

And then it die :-(((

If I choose not to upgrade maps (which maps he need to upgrade considering I do NOT have maps I don’t know) and I select Ask me Again Later, the program start and say This Program Cannot Display The Web Page) :evil:

Can you post a screenshot of the error message?

Do you ever have any trouble when using Internet Explorer on your computer? If you don’t normally use Internet Explorer, then try starting Internet Explorer and see if you’re able to surf to a few websites.

Here it is.

Obviously IE work fine with any other site, it work fine with Desktop Weather from Weather Report and any other weather site, like weather bug

When I start WW, if I choose NOT TO UPDATE MAPS (which maps? As I said, this is a clean install), here what I get:

I repeat: IE work fine with any other possible site.


I have it working in Vista x64 with no problems (other than the italics thing, Mike).

To verify you went through the proper steps:

[]Install WWL
]All installer to run WWL the first time, which allows the maps to update
[]Close WWL
]Re-open WWL - set your options and *do not set WW to use the Program Files directory (leave that setting unchecked).
]Save settings close WWL

All should be well after that.

If you didn’t follow those steps exactly (the reboot may be optional, but I have found that the placement of the tooltip window may not work before the reboot for some reason), then you may have issues.

No, it wont work for me. Same error u read up on the screenshot.

John Galt,
I too am having issues with vista ultimate 64. I have been in contact with Mike, and we traced the error to the file scrrun.dll Is there anyway that you can post your copy of the scrrun.dll, so that I may try it?
Would be much appreciated! :cool:

How to get wwl working in Vista 64

@Thepig666, here is what I just did to fix the problem:

  1. Go to start menu, run
  2. Type in “regsvr32 c:\windows\syswow64\scrrun.dll” make sure you have syswow64 in there, as scrrun.dll appears in both system32 and syswow64
  3. You should receive the message that the file was registered.
  4. Run the program!
    Hopefully the problem will be fixed! Also I do not know but think that these steps may have to repeated every time the system is re-booted, and if that is the case you could easily write a batch file to do this, and place it in your start-up folder.

Here ya go -

This is from C:\Windows\System32 …

BTW, when I posted the above post I was having no issues with WWL and Vista x64. However, on June 21 or 22 I formatted and reinstalled and then June 28 I installed WWL.

Now I am getting a slight annoyance - GetFile.exe will randomly fail.

See viewtopic.php?f=65&t=2300 for my topic on this.

@ jnelsoninjax


your fix, fixed the problem for me too on many machines. :cheers:

BTW, it fixed it also for normal WW.

@ mike

I’ve been left, after many years, WW becouse of this problem. :???: I pretty much moved all my systems at 64 bit OS level but few.

Now it is time for u to move on a Sidebar gadget: there are plenty of it, then I still miss something like WW for Sidebar (I tend to use a lot of gadgets more than applications on tray bar, I do really enjoy gadgets this days).

Bye bye from this cutie, biggie satanistic Piggie! :headbang:

PS: is it becouse of it, u lack support on initial fase of this problem? U do not like piggies, and even less satanistic piggies, don’t u??? :twisted:

thepig666, I recently added a new feature to Weather Watcher Live (and Weather Watcher) to log any errors at startup. Using that new feature and jnelsoninjax’s help, we were able to narrow the problem down to that DLL not being registered.

Feel free to bump your post if you don’t get a timely response. I’m only one person, so issues slip through the cracks sometimes :neutral: