internet connection problem with beta 2

downloaded the beta at home this morning at some ungodly hour. 6.30 a.m. It works fine - exactly as it says on the tin. running wm5 on a pda

Go to work at 9, hook the pda into proxied network and hey presto - no updates. net connection there is solid - the beta even links to the weather-com url on the main page fine - but just won’t override the proxy for the page update feed.

tried soft-resetting and repeating but no joy

come home at 6 - hook in to home net with no proxy and hey presto - all updates and all is well.

solution? are you using connection manager?

otherwise, nice app - have downloaded all your competitors and, aside from the fact you have no Today plug-in - i think this is, apart from the hassle i’m writing about :), the best.

more icons? More skins?

meanwhile, have fun!

Please try this build with your proxy server:

Sorry Mike - but the new build doesn’t solve the issue

Do you have to specify the proxy information in the other apps you use?

Hi Mike
the short answer is no - but i don’t know whether wm5 just stores a previously specified proxy and uses it if ‘asked’. I remember putting in my work’s proxy at some point - maybe to set up internet access over activesync?

If you look at the way PocketWeather handles the connection settings this might help

andy, try this one:

Note the new “Proxy” tab in the Weather Watcher Options window.

Mike - when i try to access options it crashes - irrespective of whether i’m at home or work

I cleaned out my registry and was able to duplicate that problem. The following build includes a fix for that issue:

ok - the crash is fixed but the proxy workaround still doesn’t work. Sorry

Not sure why…

In Pocketweather, for instance, you just tick a box to use ‘Connection Manager’ - which picks up your active network setting from WM5’s Settings/Connections - and applies transparently. This would be a better solution to follow i think - because otherwise a user would have to manually set up the proxy or disable it according to his network location.

Here is my first try at implementing your Connection Manager suggestion:

Well not much joy I’m afraid - when i hit the Menu button the app frezzes. If I hit the update button, i get a ‘downloading weather’ window but nothing happens. and none of the buttons at the top work.

Does this happen everytime you attempt to access the menu? Does the menu display before the app freezes?

The buttons at the top are disabled while the weather is updating. It seems that the new code cannot find your Internet connection… I’ll have to take a look.

ok i tried it again and i got no menu freeze. but still a long wait on the downloading weather data screen which is a hang.

That means the code isn’t working. Weather Watcher is waiting for an open connection… which is never found.

I’m using the HttpWebRequest class in VB.NET to make the connection. According to what I’ve read on the Internet, that class opens a connection on its own. That said, I shouldn’t have to fiddle with the Connection Manager to open a connection.

I’m not sure why it cannot open a connection when you’re at work though. I wonder if anyone else is experiencing this problem when using a connection that requires a proxy server :-s

i’m afraid I can’t really help you with the stuff other than report the problem. The only other program I’ve seen behave similarly on my PDA is Skype - which won’t connect via ActiveSync and needs the wi-fi connection. But yours did work fine via activesync at home.

It’s annoying because I imagine a big % of users work via a proxy at some point so to be viable any app needs to recognise the open connection transparently

I’ll have to research this some more and see what I can find. Keep checking back :cool:

Just like to add that I am having the same issue. The program hangs when it is parsing the weather data and I have to do a soft reset.

another thought - are you using a specific port for connection?

I looked in Start/Settings/Connections/Tasks then tapped on Manage existing connections then selected Proxy settings/advanced. My settings use port 3128.

There is also a setting for Socks which uses port 1080.


just like to say that thank god someone else is having the same problem! Not a nice thing for Mike to be sure but at least it’s not my dumb ass here. the point being that until it stopped working , i liked what i saw and would love to get it up and running properly. and so, I guess, would Mike…