Instant GPF on startup (5.5c)

So, I just discovered this program and installed it for the first time on my XP Pro SP2 system. To my surprise, when attempting to start it, I get this GPF every time:

AppName: ww.exe AppVer: 5.5.0.3 ModName: msvbvm60.dll
ModVer: 6.0.97.82 Offset: 00046163

The version of that file is from 2/23/04.

Anything to try here? Thanks.

hmmmm well Weather Watcher doesn’t ship with that dll and on my XP SP2 system I don’t have that dll and Weather Watcher runs just fine.

Find the dll and rename it to xll or dlx, reboot and retry WW and see what happens.

EdP

It does ship with SP2 (albeit an older version). Look in:
\WINDOWS\ServicePackFiles\i386

It should be in \windows\system32 as well.

I loaded up the invaluable Process Explorer (Sysinternals) to see what programs are using it currently on my system:

explorer.exe and outlook.exe are among them.

Needless to say, I can’t dump it. :slight_smile:

P.S.: Properties calls it “Visual Basic Virtual Machine”.

Did you try the 5.6 Beta 2?

Yup, it is rseiler. [:I] Sorry about that. And same version, 6.0.97.82, as yours.

Gotta love XP’s Search function.

EdP

EdP, I’ve seen that same thing happen too when using Explorer, even though I have it set to show everything. When I want to be sure about something, I use Total Commander 32 now.

OK, I just tried the beta and was encouraged by it, at first. Instead of a GPF I got an introductory message, and then one about running the configuration. Unfortunately, immediately after that the same thing happened. Now when I run it subsequently, I see the outline of the program window for a fraction of a second (blank contents) before it GPF’s again.

When I first ran it, I ran Process Explorer and saw that ww.exe does use msvbvm60.dll, along with Explorer, Outlook, Outlook Express, Opera, and Clipmate. Running WW with none of those programs running makes no difference.

Anyway, if I’m the only person who sees this problem, then I just suggest brushing this off. If it crops up with others, then feel free to contact me if you want more information. FWIW, I have a pretty “real world” SP2 installation here, so I expect WW is just not agreeing with something else that it sees.

Try installing the VB 6 Runtime package:
http://www.SingersCreations.com/VBRsetup.exe

That package, which is about four years old, contains older versions of the DLL’s that come with SP2, so due to the way Windows works (where it automagically keeps the latest versions of files for you), not a single one of those files would get installed. Is there a newer version of it perhaps that post-dates SP2?

Some of the files have newer versions, but you want the old versions. If a VB application was written using an older system file version, then you muight run into trouble if you have the newest system file.

That download package came straight from microsoft.com, so I am assuming the newest files are in the package. It wouldn’t surprise me if some of the files are pretty old – VB 6 was released a long time ago.

Wow, that’s not good. I haven’t thought about DLL Hell in years.

The problem is that installing that file won’t get me the older versions, since XP protects against older versions being installed over newer ones. The best I could do was to manually extract them into the WW directory, but that didn’t do any good because the modern versions of these files are already active in memory by their virtue of being used by any number of other programs.

I’m not quite seeing how this can be the problem though, since anyone else using XP would be in exactly the same boat: they’d be unable to use the old versions, too. Yet they don’t have the problem apparently.

If you do a Process Explorer Search for msvbvm60.dll do you find more than one copy loaded?

Are you running any older apps or games that might use VB?

EdP

No, just the one in System32, which is used by the several programs mentioned above. I would think most would see much the same on any system, and like mine they wouldn’t be using the 2000 version of the DLL either (or the 2000 versions of any of the other DLL’s). I think the only people who would are running Win9x or an unpatched W2K.

Incidentally, it’s not like the old and the new versions are all that far apart. The old one in the distributable package is 6.0.89.64, while the one I have installed (presumably the latest) is 6.0.97.82. And the one that came with SP1 is 6.0.92.37, and SP2 6.0.96.90. So there are many versions out there in 6.x, every one of which should be downwardly compatible with 6.x apps.

When I do a Process Explorer Search for msvbvm60.dll the only app it finds using it is WW.exe. And it’s the same version you have.

I’m running a Win XP Home SP2 system. But I don’t use Outlook or IE normally but even with IE open it isn’t using msvbvm60.dll. You have something added in that I don’t. What addons are you running for IE?

EdP

I don’t show IE using it either (iexplore.exe) but rather explorer.exe, which is the system shell. Why that doesn’t show for you I don’t know, but if you run Outlook or OE you should see them show up too – not that this should mean anything whatsoever to WW, but it doesn’t like coexisting with one of them I think. Plenty of programs use this DLL (I just notice Agent, the news reader, is another, along with MS Intellitype, which is the MS keyboard software).

Obviously everyone runs explorer.exe including me and I don’t see it using that dll. Nor do I see it being used when I invoke OE. Nor my browser Netscape, or Norton System Works or WinTidy or ZoneAlarm or tinySpell or PC-cillin or … [:)]

It would appear that you have an app that doesn’t like to share and is conflicting with WW. Without knowing what addins you run that use VB it’s hard to say what it is. I’ve never heard of an explorer.exe addin before. But whatever it is your running, it’s not required by my XP system.

Out of curiosity have you scanned your system for spyware?

EdP

I can’t explain why explorer doesn’t show up for you.

I don’t know if addins have anything to do with this, but most people have them (and who the heck knows if they use VB or not). You can see them when right-clicking an object in Explorer and observing the context-sensitive menu. See something like Winzip listed there? Or maybe something related to your AV program? Or any number of other things? Something that didn’t come with Windows? That’s an add-in.

And I don’t know what that has to do with this problem.

I have scanned the system.

I just tested WW in an SP1 virtual machine that has basically nothing installed in it, and I see what you’re seeing, only WW listed as using that DLL. That’s all well and good, but doesn’t explain much seeing that it’s a clean install. The bottom line is that DLL’s are meant to be shared among apps, and when an app crashes as a result, that’s a problem. That another app dares to use msvbvm60.dll, one of VB’s core DLL’s, shouldn’t be setting off any alarm bells.

quote:
Something that didn't come with Windows? That's an add-in.
No, those are called applications and they don't run inside explorer.exe thus don't show up in a Process Explorer Search as being in explorer.exe. You're seeing msvbvm60.dll as being a part of explorer.exe which indicates something has been added to explorer.exe not just to Windows, and is thus an add-in.

Rename msvbvm60.dll in Windows\system32 and see what stops working. Like I said, explorer.exe doesn’t require it so it should still come up. And worst case you can use recovery console to rename it back.

EdP

This is starting to stray far afield I fear, but it’s an interesting conversation.

First, yes, they are applications, but they do “hook” into Explorer and “run inside it,” for lack of a better phrase (even though that’s not exactly what’s happening). For example, when installing WinRAR you can tell it to integrate with the shell, which will give you those right-click goodies I mentioned. One of WinRAR’s DLL’s is then hooked into Explorer, such that you can’t even delete that particular DLL without terminating Explorer first (or, done the proper way, uninstalling WinRAR and then rebooting). The tiny SFV checker QuickSFV is another example.

Try running Process Explorer and single-click on explorer.exe; in the bottom pane you’ll see all the DLL’s that are involved with Explorer. That WinRAR DLL I mentioned above? It’s there. The QuickSFV one? It’s there. msvbvm60.dll? Yes, along with about a dozen other DLL’s beginning with “ms”. Right now, I have 41 in total hooked into Explorer.

Trying this on your system, with the exception of msvbvm60.dll, you’ll see much the same thing, the support DLL’s for those right-click Explorer items are “inside” Explorer alongside many other things. Note: In Process Explorer, you need to have View/Lower Pane View/DLL’s selected.

I’m wary of the idea of renaming the file and rebooting, since I don’t see what I’ll learn from it. I know the apps that invoke it on my system, but the mystery is why they’re doing that. Namely, why does running, say, OE invoke it while on your system and my virtual one, it does not? Learning that might be the key to understanding why when an application that really needs it comes along, such as WW, it chokes. At least WW does. One idea might be to try another application that I know for a fact requires that DLL on any system (as opposed to just mine) and see if that chokes as well. Do you know of any?

quote:
This is starting to stray far afield I fear
Not too far. We're trying to find what's on your system that is unique and interfere's with WW. Unique in that you are the only one to report this problem. There may be others. If we can pinpoint the problem we may be able to determine a fix.
quote:
tell it to integrate with the shell
This is where we differ, I have nothing integrated into my Explorer shell. I have some integrated into IE but not WE. I also use WinZIP rather than WinRAR, and that is a left over from my Win 98 days since Win XP has ZIP decompression built in.

I’m not sure what you gain from having WinRAR or QuickSFV hooked into the Explorer shell rather than into WE or simply as standalone apps. But I have no files on my Desktop, only shortcuts.

quote:
...in the bottom pane you'll see all the DLL's that are involved with Explorer. .... Right now, I have 41 in total hooked into Explorer.
Well I just found a feature that Process Explorer could add to it's display, number of entries listed. Good grief, I have 115 DLLs listed in the bottom window associated with Explorer.exe of which 9 begin with the letters "MS", none of which are msvbvm60.dll. Process Explorer also shows Explorer has 408 Handles and I have no idea what that means.
quote:
I know the apps that invoke it on my system,
Are you running the current version of the app in each case?
quote:
the mystery is why they're doing that
They're written in Visual Basic, and an older version if I'm not mistaken.
quote:
why does running, say, OE invoke it while on your system and my virtual one, it does not?
Because, in this case, you selected the option to have a VB app linked to OE during it's install. Since WinRAR works with email files I would think it would be the one but that's strickly a guess.
quote:
I'm wary of the idea of renaming the file and rebooting, since I don't see what I'll learn from it.
The thought was by renaming it a single app would fail thus identifying the culprit of the conflict. But if you have many VB apps it would not be as useful as hoped for.

Another approach would be to use MSCONFIG to limit what starts, since things that hook into Explorer like WinRAR automatically start. [:)] And in Windows XP, nothing on the startup tab of MSCONFIG has to start when Windows does. All vital system processes have been removed from that section. So in theory you can disable them all and still start Windows just fine. I would start with WinRAR, disable it, reboot, try WW. If it works we know the conflict. If not, bring MSCONFIG back up and disable another process. Repeat until WW runs. Then reenable all but the last task and repeat. If WW still starts then we know the conflicting app.

You can then check to see if you have the latest version, contact the author of the app and see if they are aware of any conflicts, inform Singer so he can test it out on his system, and rest easier knowing the problem has been identified. [:D]

quote:
Anything to try here?
Aren't you sorry you asked now? [:D]
quote:
my virtual one
I'm jealous. [:p]

EdP

rseiler, please e-mail a screenshot of the GPF error message to me at Mike@SingersCreations.com.