Garbled Map Display

Just upgraded Weather Watcher Live from 7.1.80 to 7.1.85. When clicking on the “Now” tab, the map of my local area from Weather Underground is decidedly Low Res - broken lines and letters, etc. I did not have any problems with version 7.1.80. Other than that everything is ok.

Thanks for any help you may be able to offer! Could you tell me where I can download the previous 7.1.80 version and reinstall that since it worked ok? I mistakenly deleted it when I downloaded the 7.1.85 version.

Windows 7 Sp1 64 Bit
Thinkpad T420

Edit: The map display is very similar to Chunker’s post in the today’s/yesterday’s build post. Resizing the window to a smaller size does not make any difference. I also found version 7.1.80 on a flash drive - installed that - but, no luck. Perhaps the problem is with Wx Underground? The radar pictures from are beautiful, however.

Please post a screenshot of the main Weather Watcher Live window so I can see what you’re describing.

This is the best I could do on a screenshot. I can’t get the image to display directly. As you can see, It displays in a very low resolution. I can live with it if necessary because the animated radar from is excellent.

Thank you for your help.

The current version of Weather Watcher Live streches the map to fill the width of the main window. The map image looks a little different because it’s stretched. If you right-click and drag the arrow in the bottom corner of the main window, you can resize the main window to adjust the map image. If you make the window narrower, the map image will be resized closer to it’s natural width.

As an alternative, you can click “SETTINGS” at the bottom of the main window and enter your own “Map Image Link”. That setting allows you to display the map image of your choice.

FYI, you can click and drag the strip of icons at the bottom to see the icons that do not fit in the window.

Thanks for the tip on using my own radar image, Mike. I substituted a different map url and it looks much better. The default Wx Underground radar image leaves a lot to be desired. I had never noticed that before in the Settings window. All is well now.