First Weather Watcher Smartphone Release

I put together the following Weather Watcher Mobile Smartphone build as a test to see if we can make this happen for all of you Smartphone users :cool: I don’t actually own a Smartphone, so I was only able to test this build on an emulator.

Weather Watcher Mobile 0.1 (Smartphone Edition)

Please post your feedback in this thread.

Hi Mike,

Well - it’s some time ago now, and I have still no success with my HP hw6515, so I tried this one too, but also hangs when it comes to the “Parsing weather data…”

Best Regards

Bjarne Dein

BjarneDein, which language are you using in Windows on your HP device?

Mike,

I have a t-mobile dash and just loaded up your weather app. It seems to hang on parsing weather data. I have let it run for almost five minutes and it still seem sucks. Let me knw if I can provide some additional info.

Josh

Update - I can;t get the application to quit even with the task manager, I will soft reset now. I currently have the app loaded to my sd card, maybe that is the reason it is not woring, I will remove it and install on the device and see if that makes a difference.

Update - Tried loading the app to the device, but it still is freezing on the parsing data screen.

Requirements for Weather Watcher - Smartphone Edition

What are the requirements to use the smartphone edition?

I used the Opera Mini Browser http://mini.opera.com to browse to the top of this forum on my Sprint Sanyo SCP-6600 (Katana) and clicked on the download. I was taken to my phone’s normal browser by NetFront to open the download, then received the message:

The resource cannot be displayed.  The page you are looking for cannot be opened by your browser because it has a file name extension that your browser does not accept.

I have successfully downloaded and used other applications on this phone – including Google Maps Mobile; Opera Mini Browser; and GMail Mobile.

Thank you for your new work Mike!

Patrick B

Hello Mike

Thanks for the awsome program. I’m pleased to confirm it works very well on my Motorola Q (using WMS5 brazilian-portuguese-localized). I noticed a couple things tho:

  1. I can never change the units: if i tap Menu/Options then General/Units and select the ones i want (i.e. Temp in Celsius). I do set the units and leave to the forecast screen (General/Close) just to see nothing changed. In this same screen there’s a checkbox at the botton, but since there are no scroll-down, i cannot see what’s written. i completely removed the program and .NET Cf and reinstalled it all, but it still refuses to work.

  2. (dont now if its a bug, but…) the City name doesnt appear: when i added a city, I entered the city code that appears in weather.com link and everything runs fine, but in the forecast screen the title bar only shows the city code i entered. That’s not affect the program usability tho.
    IN TIME: i saw people complaining about the “parsing weather data” thingie… first time i set up the program, i entered a wrong city code (my city code is BRXX0130) and then i got the parsing data hungup.

I hope it helps you to improve this near-perfect program :icon_smile:

Best Regards

CelsoSC, thank you :icon_smile: I don’t own a Smartphone, so I’m not able to run a test on an actual device. My Smartphone emulator is definitely a big help, but it’s not perfect.

I put together a new build with the following changes:

? CHANGED: The forecasts display the city name instead of the zip/city code.

? FIXED: “Units” section of the Options was not saving any changes that were made.

? FIXED: Realigned Options window controls so they fit inside of the viewable interface area (I’m hoping this looks as good as it did on my Smartphone emulator).

Download Weather Watcher Mobile 0.2 (Smartphone Edition)

Here’s another update with a few more changes:

? FIXED: The focus order of the controls in the “Units” section of the Options.

? FIXED: Modified date & time conversion functions to support additional international formats (e.g. Hungary).

Download Weather Watcher Mobile 0.4 (Smartphone Edition)

Still having the problem on my moto q of

1.no start menu icon created
2.running the .exe does nothing.

perhaps it’s somehow related to the fact that a while back I’d tried the pocketpc version?

mrmailer, the installer is not creating the icon for some reason. I still need to look into this issue.

I can put together a test version to step through the startup process – hopefully helping to point out the problem area. If you’d like to work with me on that, please e-mail me at Mike@SingersCreations.com.