Can't view weather window

Beginning a couple of days ago, the Weather Watcher window will not open up. When I click on “Open Weather Watcher” in the system tray, it seems to think that it has opened up. The little “weather watcher” thing shows up in the taskbar. But there’s no weather window to look at. I can click on the taskbar icon, I can right-click on it, I can try repeatedly with the tray icon as well, but nothing will bring the window up.
As I said, this started a couple of days ago. I immediately came to Singer’s Creations and downloaded the newest version, but that didn’t help. (I’m sorry I can’t confirm for you what version it is. That information won’t pop up either.) I’ve tried re-booting the computer as well. No help.

Any ideas?

Try this:

  1. Close Weather Watcher.

  2. Delete the following Registry key:
    HKEY_CURRENT_USER\Software\VB and VBA Program Settings\Weather Watcher\Misc

  3. Run Weather Watcher.

Forgive my ignorance, but how does one access registry keys to delete them? I’m not a total noob, but this is something I’ve never done.

Start --> Run and enter “regedit” sans quotation marks.

Now, navigate, using the tree on the left hand side, to the key that Ed mentioned, then delete that one particular key (again, from the left hand side tree).

Then close Regedit, then reboot.

Ok, BMinFC, let’s try a little different approach.

Close WW.
Open Notepad and paste the following lines into it’s blank window

[code]Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\VB and VBA Program Settings\Weather Watcher\Misc]
“IfaceLeft”=“0”
“IfaceTop”=“0”
“MapViewerLeft”=“0”
“MapViewerTop”=“0”
[/code]Note: The HKEY line is all one line.

Save the file, somewhere where you can find it, as WWfix.reg.
Dbl click on the WWfix.reg file and respond Ok to the prompt it invokes.
Restart WW.

Better?

Ok, I did that, and the window comes up now. Thank you.
My Virus Checker popped up a warning that there was a hidden .exe file in it, which I quarantined. That doesn’t seem to cause a problem with WW, but I’m not sure why it happened.

Happy to hear that it worked for you BMinFC.

“it”?? :-s The .reg file or WW?

I wasn’t sure which it was.

When did the warning pop up, when you dbl clicked on the .reg file or when you dbl clicked on WW.exe?

I’m afraid I don’t remember. Sorry I can’t be of more help. But the suspicious file is quarantined, and WW is working

Your AV should allow you to see what’s in the quarantine folder or have a log of what actions it’s taken recently. Can you check?

I can see the AV issuing a warning about a .reg file being used, but allow you to accept it if you want. If it’s blocked than it would be impossible to fix the problem. If on the other hand the AV is blocking one of WW’s files than that explains what happened to cause the initial problem and may indicate that it’s going to happen again. The only solutions the the latter are to contact the vendor of the AV and report that they are reporting a false positive or tune the AV to bypass the WW install folder.

Here’s what it says in the log:
Warning: Hidden extension .exe
C:\Downloaded program setup files\download-DMEXBAR13zip.exe
Moved object
Infected
The file size was 354.99 KB

!! I’m not sure what caused your AV to catch it when it did but I see it having no bearing on anything WW related. Good to know. :icon_smile: Thanks for the update BMinFC.

BTW If you still want to try DMEXBAR13.zip download it from here: http://sunsite.rediris.es/pub/mirror/si … p/fileutl/ The exe version has Simtel’s downloader wrapped around it.

I don’t even know what DMEXBAR13 is or why I would want to try it.

:-s Then how did it get on to your pc? It’s not a virus or spyware so it didn’t get there via some infection or malware.

What it is: http://www.freewaregenius.com/2008/02/0 … -explorer/

I have no clue. I went to the link you provided and saw what it’s about, and I had certainly never heard of it before. Totally freaky. And my AV said it was a “hidden .exe,” so it was hiding somewhere.

One of life’s great mysteries…