WW won't update or city search

I had a computer lockup (XP Home). After straightening it out, everything worked as before except WW will not update data or search if city entered. I uninstalled/reinstalled (even dl the pkg again) but it still does same–will not hit the internet to update. Other internet pgms work fine (web, email, etc). Ideas?

In another topic, ““Server Not Found” when searching for cities” I saw a note by EdP that dl.exe must access the internet. A search of C: finds no dl.exe; could this be part of the problem. Wouldn’t the full reinstall have put it back in?

If DL.exe is not in the WW folder it will indeed cause problems for WW. And a reinstall should indeed reload it. Which implys that you have something that is “deleting” it. Check you antivirus and antispyware logs and see if any of them has it in their quarantine folder. I seem to recall awhile ago some AV was falsely flagging the file, but that was last year or so.

The only other option I can think of is the install file you downloaded is bad but if that were the case I think you’d have a lot more problems than what you’re experiencing, but it is a possible explanation.

It was not quarantined. I reinstalled WW again (this time without removing all traces of it as I did before) and found it by rt-click WW folder icon and selecing Search from there. dl.exe exists in \program Files\Weather Watcher. Search from Start button DOES NOT FIND IT ON C: drive!! The MS search function clearly has a bug. I also see the file just viewing the dir contents. 28K, 7/12/05.

I suspect now the file WAS THERE before…MS search just was not showing it. So, I try to enter a city by zip code, and get “Server Not Found.” Trying by entering a city name produces a Searching…" message, but no results. I know there was a server not found problem, but thought that had been patched. My install file is 569.


And you can access http://www.weather.com using IE yes?

Yes, using either Firefox or IE. Both will open http://www.weather.com .

Problem solved…I use Ad-Subtract. After you mentioned weather.com, I added that to the Adsubtract sites list, and removed almost all filters for it except Java applets. Now WW works! But it is strange that it previously worked without have to be allowed in the Adsubtract filters.

Of the following, which must be allowed for WW to work:
Bckrnd Images
Bckgrnd music
Cookies *
Java apps
It must be one or more of those WITHOUT * because * items were already being allowed by default while the problem existed.

Glad to hear you found the source of your problem. :icon_smile:

The ones with the * should be all you need for Weather Watcher. It uses Javascript and cookies. There are weather icons that can be selected that are animated but the basic ones aren’t. There is no music associated with WW but it can assign sounds to events, like alerts.

I don’t use Ad-subtract so I don’t know what to tell you. If you could do some experimenting and report back the minimum Ad-subtract requirements that you find to work it would be most helpful to others that follow.

Well, this is totally weird. I added the filters back in, one-at-a-time, checking update ability after each change. It worked each time. So, I removed weather.com from the filtered sites list (meaning it reverted to the same configuration as before–using the default settings), and it continues to work. As best as I can tell, I am now in the same configuration as when it was not working, but now it does. Go figure.

Have you rebooted since making the changes?

Yes, I had rebooted and just did again. It still works with Adsubtract filtering set just as it was while the problem was manifest.

It seems to be one of those computer things that drives you nuts. At least it started back working for me. I was hoping that doing the one at a time re-filtering would have identified the required facility/capability that was stopping it, but it didn’t–refiltered as before and it continued to work.

Quick, image the hard drive before something else fails. :laughing6:

Anyways, it’s good to hear that you got Weather Watcher working again.

Hi Mike,

I was having this problem on and off and then it began in ernest with 5.6.8. An update to 5.6.9 didn’t help. I solved the problem by deleting the Weather Watcher registry and having it rebuilt it. I know all my settings so this wasn’t too much of a drag. My locations were unaffected. Yea!


FYI Locations aren’t saved in the Registry. They are saved in the WW file CityCode.cmd.

What does deleting the WW registry mean?

Most of the ww settings are stored in the following Windows registry key:
HKEY_CURRENT_USER\Software\VB and VBA Program Settings\Weather Watcher

If you delete that key, you’ll reset your Weather Watcher settings.

You could perhaps add a button for doing this, somewhere in the program? Kind of an emergency recover…
And maybe buttons to export/import settings…?

I think this might help some users to check if it’s their problem is setting-related…

Not updating: server not found

5.6.9 quite updating approximately 12:00pm central standard time. It is on 3 computers now and can’t get any to update. Mine has been fine all along until yesterday. Fire wall techs are looking into it on their end but did nothing to cause it. They are asking for the IP address it hits for the data packet. I can go to weather.com. Does the dl.exe hit the address or is it another?


Well if it’s happening on three pcs it’s not a Windows or Weather Watcher problem.

Don’t know if DL.exe uses the address. It does use a URL of xoap.weather.com.

weather.com does switch IP addresses around periodically to balance their load. That’s why it’s better to use the DNS.

Just to make sure there is not a problem at the other end is anyone recieving updates at this moment? Firewall tech says as far she can tell it is not blocked and they made no changes after 12:00pm CST yesterday. I have had it installed about 4 months on this PC and fresh installs on 2 others this morning to see if it was mine. I have had zero problems until now. Thought something might have happened on the weather.com end?

Not sure what it hits to check for updated versions but it does come back with “you are using the latest version of weather watcher”. Anything else I might do to help diagnose this?