WW always defaults to same date

Using Vista (yes I know its $%^*) and I cannot update my WW.
I have tried uninstalling completely and starting again with the latest version and all is well - date weather etc all ok.
Restart my computer and it defaults back again to values from 14th February 2008 everytime. Goes through parsing stage but nothing updates. Must be a registry problem?
Hope you can help.

Thanks,
Great program (or it was when it worked!)

Not necessarily.

When you boot your pc what version of WW comes up?
When you print a WW forecast screen where does the page’s location show it’s printed from. (Be sure the Page Setup shows the &u&b&d string in the footer)

When you install a new version of WW and start it what version comes up?
When you print a WW forecast screen where does the page’s location show it’s printed from.

Version is 5.6.25

London, United Kingdom
Observed Wednesday, February 13 @ 12:50 PM Local Time @EGLC
Downloaded Wednesday, February 13 @ 1:25 PM
Active City missing from Options (Re selecting London and Apply has no effect)
Prints from: file//C:Program Files\Weather Watcher\Skins\Splendid\Current.html 11/04/2008

New installation after uninstalling program. All correct initially
London, United Kingdom
Observed Wednesday, April 11 @ 08:50 AM Local Time @EGLC
Downloaded Wednesday, April 11 @ 9:16 PM
Prints from: file//C:Program Files\Weather Watcher\Skins\Splendid\Current.html 11/04/2008

Shut down program and restart - everything back to

London, United Kingdom
Observed Wednesday, February 13 @ 12:50 PM Local Time @EGLC
Downloaded Wednesday, February 13 @ 1:25 PM
Active City missing again from Options
Prints from: file//C:Program Files\Weather Watcher\Skins\Splendid\Current.html 11/04/2008

HELP!!

Is that from the WW About screen each time?

Do you have this folder?

[size=2]file://C:\Documents and Settings[i]your windows id[/i]\Application Data\WeatherWatcher\Skins\Forecasts\Splendid[/size]

Version 5.6.25

Yes version 5.6.25 indicated by right click - about at all times.

Today
Repeated uninstall. Downloaded V 5.6.25 again. Reinstalled. Set up city. All OK.
Closed program.

Opened program. Back to Feb 13 again. Active City lost again
Version 5.6.25

Prints from
file//C:ProgramFiles\WeatherWatcher\Skins\Forecsts\Splendid\Current.html 12/04/2008
(On my previous message I may have missed out “Forecasts” on my print from list as I manually typed that in?)

I do not have this file
[file://C](file://C):\Documents and Settings\your windows id\Application Data\WeatherWatcher\Skins\Forecasts\Splendid

Thanks for your help.

Re: Version 5.6.25

:shock: Interesting that you can repeat the problem without rebooting. That’s a new piece of information.

What do you have in your C:\Documents and Settings[i]your windows id[/i]\Application Data\WeatherWatcher folder?

When you install WW and it comes up I assume the installer is starting it and when you manually start it you are starting it from a desktop icon is that correct?

The next time you install the new release and while it is displaying the current weather lets try some things:

  1. Open the C:ProgramFiles\WeatherWatcher\Skins\Forecsts\Splendid\ folder, note the date/time stamps of the html files.
  2. Dbl click on the current.html file such that it opens in IE. What date is it showing for the weather?
  3. Scan your c: drive for current.html files.

Close down the newly installed WW and repeat the above 2 steps.

Restart WW like you normally do and repeat the above 2 steps.

My suspicions initially were that someone when you were rebooting Windows was doing a System Restore for some reason and wiping out the WW upgrade but with the new senario you describe that’s not the problem.

My current thoughts are leaning now to you somehow having two versions of WW installed and the desktop icon is pointing to the original install or some security software is automatically reverting it back to the original. The 25 version of WW introduced the Windows Profile folder for saving key WW files, older versions wrote everything to the WW install folder. I think you are getting caught in the middle somehow.

Interesting that you can repeat the problem without rebooting. That’s a new piece of information.

Caja wrote:
I do not have this file
[file://C](file://C):\Documents and Settings\your windows id\Application Data\WeatherWatcher\Skins\Forecasts\Splendid.

What do you have in your C:\Documents and Settings\your windows id\Application Data\WeatherWatcher folder?

I do not have this folder.
Only have C:\Programs\Weather Watcher\Skins etc.

When you install WW and it comes up I assume the installer is starting it and when you manually start it you are starting it from a desktop icon is that correct?

Yes

The next time you install the new release and while it is displaying the current weather lets try some things:

  1. Open the C:ProgramFiles\WeatherWatcher\Skins\Forecsts\Splendid\ folder, note the date/time stamps of the html files.
  2. Dbl click on the current.html file such that it opens in IE. What date is it showing for the weather?

Today’s date

  1. Scan your c: drive for current.html files.

Only today’s date found

Close down the newly installed WW and repeat the above 2 steps.

Current.html = Today’s date

Restart WW like you normally do and repeat the above 2 steps.

Reverts to 13th FEB as before
Current.html = Today’s date

I have scanned for any other “weather” files and found no residual tyraces of old install.

Ah yes, that’s true, you don’t have a c:\Documents and Settings folder in Vista you have a c:\Users folder if I’m not mistaken. So everywhere where I mentioned Documents and Settings folder interpet it as the Vista’s Users folder.

According to the write up for 5.6.25:
“CHANGED: Weather Watcher user settings files have been moved from the Weather Watcher program folder to the current user’s Windows profile.”

And at some unoffical release version of .25 the skins got moved to the Users’ WW folder also.

More things to check out;

When you RIGHT click on the WW desktop icon what shows in the shortcut’s Properties’ Target box?

In your WW install folder do you have a Default.ini file?

When running WW and getting the old forecast data, from a Command Prompt window run:
regedit.exe /e c:[b]old[/b]WWdata.txt “HKEY_CURRENT_USER\Software\VB and VBA Program Settings\Weather Watcher\Current”

When running WW and getting the current forecast data, from a Command Prompt window run:
regedit.exe /e c:[b]new[/b]WWdata.txt “HKEY_CURRENT_USER\Software\VB and VBA Program Settings\Weather Watcher\Current”

To reduce time, and error, running the two regedit commands it might be more convenient to put them into .bat files and then run the .bats from the Command Prompt.

More things to check out;

When you RIGHT click on the WW desktop icon what shows in the shortcut’s Properties’ Target box?

“C:\Program Files\Weather Watcher\ww.exe”

In your WW install folder do you have a Default.ini file?

Cannot find WW install folder or Default.ini

When running WW and getting the old forecast data, from a Command Prompt window run:
regedit.exe /e c:\oldWWdata.txt “HKEY_CURRENT_USER\Software\VB and VBA Program Settings\Weather Watcher\Current”

When running WW and getting the current forecast data, from a Command Prompt window run:
regedit.exe /e c:\newWWdata.txt “HKEY_CURRENT_USER\Software\VB and VBA Program Settings\Weather Watcher\Current”

Run both - no change to problem. :cry:

You can’t find

:shock: Are you sure you tried? :-s

Please post the contents of the two files those commands created.

c:\oldWWdata.txt

and

c:\newWWdata.txt

Caja wrote:
In your WW install folder do you have a Default.ini file?

Cannot find WW install folder

Are you sure you tried?

I made a full search “Everywhere” with no files hidden. I am using Vista so who knows what’s going on 8-[

Here’s the contents of the Old and New.
Program displays 13th Feb still and old data.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\VB and VBA Program Settings\Weather Watcher\Current]
“Downloaded”=“13/04/2008 13:29:09”
“OldSevereCode”=""
“OldSevereID”=""
“AlertsAvailable”=“False”
“AlertCount”=“0”
“City”=“London, United Kingdom”
“Latitude”=“51.50”
“Longitude”="-.13"
“Time”=“1:29 PM”
“Rise”=“6:08 AM”
“Set”=“7:55 PM”
“Updated”=“4/13/08 1:20 PM Local Time”
“Location”=“EGLC”
“Temp”=“48”
“TempC”=“N/A”
“Feels”=“45”
“FeelsC”=“N/A”
“Condition”=“Partly Cloudy”
“Icon”=“30”
“Bar”=“29.80”
“BarChange”=“steady”
“Wind”=“7”
“WindGust”=“N/A”
“WindDirection”=“S”
“Hum”=“76”
“Vis”=“6.2”
“UV”=“N/A”
“UVLevel”=“N/A”
“Dew”=“41”
“DewC”=“N/A”
“MoonIcon”=“8”
“Moon”=“Waxing Gibbous”

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\VB and VBA Program Settings\Weather Watcher\Current]
“Downloaded”=“13/04/2008 13:29:09”
“OldSevereCode”=""
“OldSevereID”=""
“AlertsAvailable”=“False”
“AlertCount”=“0”
“City”=“London, United Kingdom”
“Latitude”=“51.50”
“Longitude”="-.13"
“Time”=“1:29 PM”
“Rise”=“6:08 AM”
“Set”=“7:55 PM”
“Updated”=“4/13/08 1:20 PM Local Time”
“Location”=“EGLC”
“Temp”=“48”
“TempC”=“N/A”
“Feels”=“45”
“FeelsC”=“N/A”
“Condition”=“Partly Cloudy”
“Icon”=“30”
“Bar”=“29.80”
“BarChange”=“steady”
“Wind”=“7”
“WindGust”=“N/A”
“WindDirection”=“S”
“Hum”=“76”
“Vis”=“6.2”
“UV”=“N/A”
“UVLevel”=“N/A”
“Dew”=“41”
“DewC”=“N/A”
“MoonIcon”=“8”
“Moon”=“Waxing Gibbous”

At this point I don’t know what else to try. Sorry. :sad:

Caja, are you logged into Windows as an administrator? If not, give that a try and see if it makes a difference.

Also, you might want to try temporarily disabling Windows Vista UAC – if it’s enabled. That will at least tell you if Windows is blocking Weather Watcher from accessing the registry (most likely not the case) and/or from writing to the Weather Watcher progam folder.

Administrator

Hi,
I am logged in as administrator and have tried running without various security options running. I have cleaned the registry and gone through other uninstall clean-up programs. Nothing seems to work. I have another PC running the same version of Vista and WW works fine on that one.
How did Vista ever get released onto an unsuspecting world? :cry:

Thanks for all your help,
I guess that’s it.

Caja, after you sadd new cities in Weather Watcher, do you see the following file?

C:\Program Files\Weather Watcher\CityCode.cmb

If so, try opening that file in Notepad (or another text editor) and check if the cities you added are inside of that file. If they are not there, then it seems something is preventing Weather Watcher from writing to that file.

City code

Caja, after you sadd new cities in Weather Watcher, do you see the following file?

C:\Program Files\Weather Watcher\CityCode.cmb

No, this file is not there.
I have a friends computer (with Vista) that runs WW ok. This has the citycode file. I copied this to WW on my machine and the problem still occurs. Opening the file does contain the London United Kingdon Kingdom UKXX0085 code.
I’m sure you are on the right rack when you thought it must be something to do with the city code though as this always disapears after the first launch of a new re-instal.

Weather Watcher creates the “CityCode.cmb” or appends to it if it already exists when you add new cities in the Weather Watcher Options window. It seems that Weather Watcher does not have write access to “C:\Program Files\Weather Watcher” on your computer.

Did you disable Vista UAC?
http://disablevistauac.com

If WW can get installed to that folder why can’t it write to it??? :???: That doesn’t make sense.

Perhaps the Weather Watcher installer had access to write to that location at install time.

Perhaps but WW also had the ability to create html files since the forecasts were current initially after the install.

And to update the Registry, if that’s where WW get’s it’s forecast data.