WW 5.6.19 and Win2K

I have both WinXP systems and Win2k. It appears that 5.6.19, 19a, and 19b all don’t seem to be able to update from the outside world on my Win2k system. When I change back to 5.6.18, it works fine and the 5.6.19’s work fine on my XP system. When I click on update, it puts up the progress bar very briefly, the little blocks never change color, and then the progress bar disappears. My guess is that it’s reading the data from the cache, but I haven’t found a way to make it stop doing that. Any help?

The following build should resolve that issue:
http://www.singerscreations.com/Forum/viewtopic.php?t=1608

Thanks Mike, but that didn’t do it. I assume you meant the 5.6.20 release, but that behaves the same. I’ve tried changing the IE cache setttings to no avail. Any other ideas. It’s fine on XP and doesn’t work on 2k. nb. there’s no problem with the internet connection and 5.6.18 works just fine.

17:45 PST
Just for yucks, I put the dl.exe from 5.6.18 in with 5.6.20 and it works fine. Looks like the new changes to dl.exe are doing something to make it not function with Win2k and IE 6.

zoundz, please try downloading a new copy of the Weather Watcher setup from the following link:

http://www.singerscreations.com/AboutWeatherWatcher.asp

I found that some of my mirrors had a slightly older version of the latest setup. I double-checked all of the setups, so you should be good to go after you download a fresh install.

Hi Mike. Still not happening with 5.6.20a. I have no clue. The only thing different about this one is that the update button was missing from the left corner of splendid and replaced with a list box selector which did produce the update button when clicked. ???

http://whathefayla.com/Pix/ww.jpg

Once again, the old dl.exe works fine once the button gets on the screen.

I’ll keep trying new ones as long as you keep making them.

BTW, in case I haven’t mentioned it, thanks for creating a terrific little app. Much appreciated.

Regards

zoundz

zoundz, I’ve experienced the issue with the “UPDATE” button before. That happens when the interface does not load properly. I haven’t been able to reproduce the issue, so I don’t have a fix at this point. I always find that restarting Weather Watcher resolves the issue.

Does the following build resolve the downloading issue?
http://www.SingersCreations.com/Files/zoundz/setup.exe

Still no joy, Mike.

I installed that one on the 2k system and it behaved exactly as the previous ones. I installed it on the XP system and it work just fine. Both systems are totally up to date with M$ fixes and both systems are running IE 6. Once again, going back to the dl.exe from 11/15/2006 solves the update problem.

One other interesting thing. The 2k system routinely displays a blank frame with the WW logo when I install a new version. To fix that it’s necessary to go to option/skins and change the skin to classic and back to splendid for both the interface and forecast skins. Then the display is right. On the XP system this is not necessary. The window comes up correctly right out of the box. There’s just something funny about WW’s interaction with Win2k. The whole thing may be moot, but there are an awful lot of people out there still running 2k.

Regards

Zoundz

Does the new dl.exe work at all on your Win 2k system?

For example, if you switch to a different city, does the data download for that city? Are you able to add new cities in the “Active City” tab of the Weather Watcher Options window?

Does the new dl.exe work at all on your Win 2k system?

For example, if you switch to a different city, does the data download for that city? Are you able to add new cities in the “Active City” tab of the Weather Watcher Options window?

The new dl.exe seems to do nothing but throw the progress bar momentarily. There appears to be no effect other than that. I can tell it to change cities and it throws the progress bar twice, but the blocks do not fill in and the new data is not downloaded.

And no, I can not add a city with the new dl.exe. When I type a city name, it says “searching” and never finishes. Again, switching to the old dl.exe works fine with the latest other code.

Try the following:

  1. Click your Start button and select “Run…”.
  2. In the Run window, type REGSVR32 URLMON.DLL and click “OK”.

Does Weather Watcher work at that point?

  1. Click your Start button and select “Run…”.
  2. In the Run window, type REGSVR32 URLMON.DLL and click “OK”.

Does Weather Watcher work at that point?

Nope. didn’t do it. Next? :icon_smile:

Added note:

I snooped the tcp/ip connection and it does appear that the dl.exe that fails DOES succeed in communicating with desktopfw.weather.com. It sends the request and gets back some web page info. It does not go get the moon icons after that, tho and does nothing else. It appears that the problem is happening when it tries to decode the returning web page. I wonder if it’s different when weather.com detects Win2k as opposed to XP. The saga continues…

Zoundz

desktopfw.weather.com!!! :shock: Not xoap.weather.com??? :-s

desktopfw.weather.com!!! Not xoap.weather.com???

yes definitely

http://desktopfw.weather.com/weather/local/USCA0139?&cc=*&hbhf=100&cc=*&dayf=10&cc=*&dayf=0&ut=F&ud=M&ur=I&us=M&up=I&fwiam=100

I wish I had a Win 2k box to test this idea. Maybe some other Win 2k users are reading along and can share their experience.