Use custom tray tooltip window location not working

Hi, I have this app (v 5.6.25) running on a couple of different systems. The application is showing the temperature correctly, no problem at all with its funcionality however I have two environments using dual display and I am having a minor issue in one of them. In one of those envs the tooltip is displayed in the lower right corner without any extra config (no manually configured to be there) on the other system the same tooltip is in the center of the screen without any extra config. If I try to set the tooltip location to the lower right corner it does not work. I tried several different locations and it does not matter, the tooltip will continue appearing in the middle of the screen no matter what location I chose. In the other dual display environment this option is working, but it is not necessary since by default the tooltip is in the lower right corner (this is where I want the other to display too).

Some extra info from the non working env.

Main Screen: Viewsonic 21’ @ 1680x1050
Secondary Screen: Viewsonic 19’ @ 1280x1024

I checked on the install folder, but I dont see any config file, is there something (config file, registry) where I can try to manually force the change? I know this feature works because I have it working on other systems, but in this particular system it does not work, this is the only env with a widescreen lcd, maybe thats the problem.

Any suggestion or help?

Is your main screen on the right or left?

Both dual display systems are configure the same. Main screen on the left.

I’m experiencing the same thing where the tray tooltip is always coming up in the center of the screen. I’m running Vista Business (32bit) on a laptop. I’ve never had a second monitor hooked up, but Vista knows about the external monitor port and shows the laptop screen as on the left in the monitor configuration. Has anyone figured this out yet?

Do you have the WW Tray Tooltip option to Use a custom window location enabled?

Initially it was not enabled, and it was centered in screen. Then I tried enabling and moving it, but it still always comes up in the center of the screen.

After you move it make sure you click the Apply button on the Options window. Easy to overlook but necessary to do.

Yes, that does not make a difference. Always displays in center of the screen.

… Hmm, very interesting.

I had to exit WW and restart it, and now the positioning works fine, both default and custom.
I had never shut it down after the initial install. I rarely reboot this computer. After Exit and then running it again, everything is fine.


I noticed that as well the last time I did a fresh install of WW on Vista - after restarting it all was well.

Since you are on Vista, I am assuming that you run the initial run that the installer gets you to run - the problem with this is that the installer passes on its elevated privileges to the WW program when it is run - and thus, you are running WW as admin - and when you make changes to the options, things like tool tip placement seem to not work until you close WW and run it again - this time without elevated privileges.

I am not 100% sure that is the cause but it is similar to symptoms I have seen in other apps that end users run from the end of the installation process. Unfortunately, with WW< you almost have to run it with admin privileges the first time so it can update the maps and such, so I suggest that you, in the future, install it, run it from the installer, allowing the maps to update, then immediately close it. Now run it again from the desktop shortcut, and set your options.

You should have better luck doing it this way.

Of course, if you ‘upgrade’, IOW already have WW installed and simply run an installer to update to the latest version, this should not be required - your settings should all be preserved.

I noticed this also on one of the recent installs but I don’t remember off hand which one. It was the one where I posted I was going to revert to the prior release.

But this was an upgrade on a single user XP system so Vista and Admin rights played no part.

If more XP users can chime in that this happens all the time, then it may be something in the code that Mike changed…perhaps in order to accommodate Vista users in the first place…

But it could also have been a glitch in that one particular version, and if it hasn’t done it since…who knows?

This worked for me as well. I unchecked/rechecked the custom tooltip checkbox, place the tooltip where I wanted it, shut down the app, relaunched and it is where I placed I wanted it. Otherwise, it would just go back to the center of the screen.

I’m running Vista Ultimate with a single widescreen monitor.

I noticed that as well the last time I did a fresh install of WW on Vista - after restarting it all was well.

I can confirm this as well. It seems to take a strange combination of rebooting the system, and launching/closing WW to finally get the tray tooltip to appear in the location I want it to. Even the default setting would have the tooltip appear dead center of the screen. Vista ULT.[/code]