Mike is there anything wrong with the program update link? Anybody else having trouble using the program built in update link? I usually check everyday and today mine gives an error of unable to check for an update. Never had this before, wonder if it is just my pc or others?

Here’s a screenshot of what I’m getting. It always worked almost instantaneous in the past, now a short delay and this message.

How about now? It seems to be working okay at the moment.

Just now gave it a try and still not working for me. Get the same error message.

What happens when you go here?

Sorry but my browser won’t let me access the url you posted. Firefox told me it was untrusted and then I approved adding access, then my Norton online DNS wouldn’t let me either. They both say untrusted. What I’m gonna do is a restart and see if that helps??? Back to let you know the results shortly.

Something on your computer is blocking all access to http://www.boxcn.net.

Well, after the update, same thing. Then I tried the other url you sent and I get there fine. Can’t figure out what has happened to stop my update of your program. Never changed anything here, but I remember Firefox did an update a few days ago, maybe that is it? Gonna try that other url with IE and see if it gets through???

I guess it had to do with my Norton DNS blocker that I had installed on my pc many years ago. It has worked fine for years but now all of a sudden it started blocking your update link. That’s probably the “only” thing I’ve ever seen it block. I went ahead and removed the protocol from my settings which shut it down and now I can get through fine and no more update error message. Thanks for pointing me in the right direction!