System Tray Temperature Appearance

I am also one the ones who has an ugly temperature display in my task bar. I have been able to fix it somewhat. In Options -> Tray Icon -> Tray Icon Look & Feel I changed the Font color to black, and the Background color to a light blue (Hue 142, Sat 240, Lum 149, Red 61, Green 149, Blue 255) that matches (similarly anyway) the default light blue in XP. I also had to turn of Make Transparent.

I do see a slight border, so if anyone has any better values I’d appreciate hearing about it.

If you are unfamiliar with this problem I can take before and after screen shots.

Thanks,
Chris

What kind of monitor are you using? Do you have Clear Type enabled?

Dell Core Duo laptop w/ LCD. I do have ClearType turned on. When I turn it off the problem goes away. Thanks.

BTW, the other text in my system tray (for example internal temperatures displayed by “Notebook Hardware Control”) do not have this problem. Is this considered a known bug in WW?

Also… for this interested in details of my workaround… the background blue is impossible to match exactly… because it switches color and fades as it goes, but, to my eye, this blue looks best: Hue 142, Sat 240, Lum 140, Red 43, Green 138, Blue 255. Also, I wanted the Font to be white, but that caused more problems, I fixed them by going almost white: Hue 160, Sat 0, Lum 238, Red 253, Green 253, Blue 253.

Thanks,
Chris

The color white and transparent backgrounds have been a problem for a long time. There is indeed a link between Clear Type and the transparent background option, hopefully that knowledge will aide in determining a solution.

I use Clear Type because the LCD screen looks pathetic when it’s not enabled so not using it is not an option. For WW I use a background color that makes the temp standout. RGB 132,7,99. And for the white digits I have used 251s and 254s but your 253s work also. Pure 255s do not work.

It’s not a problem for everyone though. Check out the following screenshot of my desktop when using ClearType and a transparent tray icon:

ClearType Screenshot

Unfortunately that will make it tough for you to resolve the problem.

There is something(s) that you have to check for and then adjust some parm based on what you find. It could be a video card, a video driver, an OS patch, a particular combination of apps or simply a particular font.

Maybe you could develop a utility that displays certain system variables and environment that those of us that experience the problem can run and send the findings to you.

BTW I have the problem on my desktop but not my notebook and both have LCD screens. The notebook uses Intel Graphics and the desktop uses ATI.

I just use the Terminal font. I haven’t had any problems with it using clear type. Other fonts cause the same “shadow”, which make it impossible to read. Same thing happens with the settings Mike posted above. :slight_smile:

That was my solution too. Most other fonts give me the same problems as above. It is definitly a combination of Clear Type, transparency, and monitor type (such as LCD), perhaps other factors. I’ve been happy with the Terminal font, but it’s not for everyone. My laptop has an ATI video card just like Ed’s desktop. Maybe that’s a clue. http://www.wizdforums.co.uk/images/smilies/shrug.gif

Alright my curiosity was peaked.

On my desktop machine, with Clear Type enabled, I am able to switch between a WW Background color and a Transparent background with no visible change to the digits with these fonts:

Terminal
Script
Roman
MS Serif
MS Sans Serif
Modern
Fixedsys
Courier

These were all tried with a Font Size of 9 Bold and a font color of 254x3. They are all Bitmap fonts.

I tried Small Fonts, another Bitmap font, and while it didn’t change either, it didn’t look good in either case and the System font was not an option to select.

The use of True Type fonts caused extreme ballooning of the digits when the WW Background is made transparent.

WW could minimize the problem by excluding TT fonts as an option.

Got a screenshot? :cool:

:shock: You’ve never seen it where it looks right??

It looks like the image you linked to. :icon_smile:

Well, you said you were having troubles, so I wasn’t sure how clean the icon looked :icon_smile:

How does Verdana look? That is what I used in my screenshot.

Per your request sir. :icon_smile:

http://img155.imageshack.us/img155/7339/wwiconfontfv6.th.png

The digits are bloated and have a slight slant. If you’d like I can email you the bmp.

Agreed. Maybe the tray font text just looks clearer because your using white font? I usually hear that the ClearType setting adds white around the text, so it’s hard to tell what is happening in your case.

Maybe, but the impact is greater with TT fonts.

http://img264.imageshack.us/img264/3903/wwiconfont2mw2.th.png

Straight Bitmap fonts do not have the problem.

http://img520.imageshack.us/img520/9052/wwiconfont3rr6.th.png

BTW Why is the System font not an option.

http://img330.imageshack.us/img330/435/wwiconfont4ue3.th.png

No idea… it doesn’t show up on my computer either. VB does not enumerate it for some reason.

I am running Windows Vista and the best combination I could find so far was to use the following options:

Font = Terminal
Size = 10 (Normal)
Font Color = White
Background Color = Black
Make transparent = Checked

Also, make sure that you disable the option to display the degree symbol.