Link to the local file

How do I create a link to a local file that is located in the skin folder?
How do I add the link to a local file to the Map Manager?

I tried simple href=“file.html” for both, but it doesn’t work.

In the Stone Soup Current.wtp file I have a link to a local file specified with the anchor href option that works.

List of <A HREF="Changes.html">enhancements</A>.<BR>

This in turn is passed to the forecast’s .html page unchanged and works well.

What does your href line look like?

A link in the Map Manager may require the file’s whole path which could be troublesome.

My link looks exactly like yours, and the file is located in the AppData/Roaming/WeatherWatcher/Skins/Forecast/MySkin folder.
When I click the link nothing happens; just nothing. Though if I put into HREF any web URL like it opens a new browser window with this URL.

Something different happens in Map Manager…
When I create a new map and make the Map Link look like this it works fine, but if I create a file map.html in my skin folder with <iframe src=""></iframe> and put a link to it in the Map Link field, it shows a javascript error with the message “Invalid character” and does not show the contents of the iframe, but it DOES show everything else in the map.html.

Does anybody have any idea what is going on? :-s

Ok, so that we are on the same page, the file you are linking to is an html file, in the same folder as your WW .wtp file, yes?

If you open the Forecast’s html file in IE and click on the map link does it open then? When viewing the forecast in an IE window how does the Properties of the link compare to the URL for the forecast file in the IE Address window?

If you would like to upload the two files somewhere I could take a look at them for you.

Are you using any of the WW [INSTALL LOCATION] tags in your links? :-s hmmm with the move of the Skins and etc files and folders to the Windows Profile folders is/are there new WW TAG(s) indicating the new location of the Skins Mike??

Try the following build:

Here are the new profile tags:
[PROFILE LOCATION] = C:\Users\HP_Administrator\AppData\Roaming\WeatherWatcher
[PROFILE LOCATION ESC] = C:/Users/HP_Administrator/AppData/Roaming/WeatherWatcher
[PROFILE LOCATION SLASH] =C:\Users\HP_Administrator\AppData\Roaming\WeatherWatcher

Ok, something wierd is happening…
When I put in href ANY URL containing “C:” (either typing it by hand or using your tag) the IE somehow thinks that the actual path starts with “file:///C:/” - with three slashes instead of two!
I checked - the link works with two slashes, but I cannot make the IE put the right path in there; whatever I do it shows “file:///c:/…” and of course it does not work.

I’m stuck :confused3:

Try \s in your URL rather than /s. Now you see why there are multiple formats to the LOCATION tags. :lol:

If I’m not mistaken you can also use relative paths, such as …Icons\ etc, rather than absolute paths for the URLs.

Thanks, Ed, but as I said before this three slashes thing happens always regardless of what tag I use.

Looks like some kind of WW/Vista/IE conflict…


This href: List of <A HREF="../Changes.html">enhancements</A>.<BR>
expands to this link: file:///C:/Documents%20and%20Settings/Owner/Application%20Data/WeatherWatcher/Skins/Forecasts/Changes.html

which works just fine for me both within WW, within IE and even within this posting. :shock:

Do note that the HREF points to an html file that is not in the same folder as the wtp files nor begins with a C:. Also note that the link begins with “file:” and 3 /s and works just fine.

As a quick experiment I dbl clicked on a Vista Current.html file which opened in IE, I then added “file:///” to the front of the URL in the Address window and it reopened just fine. Note the mixture of slashes in the resulting URL: file:///C:\Documents and Settings\Owner\Application Data\WeatherWatcher\Skins\Forecasts\Vista\Current.html

So “file:///” is a valid URL prefix for IE, regardless of the URL’s other slashes.

I think something on your system is interfering with links to files on your pc. Could be an IE setting, a Vista setting, some other security app setting.


Yeah, I do exactly the same things. Except the link won’t open in IE. Though if I rightclick on it and do “copy shortcut” and then insert it to IE address bar the URL transforms into a normal path “C:\Users\Owner\AppData\Roaming\WeatherWatcher\Skins\Forecasts\Vista\file.html” and opens OK.

If it works for you, then I suppose the problem is in either my IE7 or Vista OS.

As I said before: I’m stuck… :banghead:

I just tried it on my machine with IE 7, it works there also.

FWIW The linked html file has these lines at the top:[code]