Hourly update still not working

I’m getting the wrong times and days in both the hourly update and the detailed forecast. I tried:

– running the update
– uninstalling and reinstalling from scratch
– running the update on top of the new install

Still no banana. It thinks it’s Tuesday.



Did you try reinstalling Weather Watcher from a new download?

Yes. Once on top of the original installation, and once I removed the whole program by going to Add/Remove Programs and then reinstalled off that link. Still have the same problem.

When you retrieve the weather, do you see the status window open, and do all of the teal bars fill up?

Yup, I get “Downloading weather data” and “Processing weather data” and all three bars fill up.

What Active City are you using? What region is selected in the “Regional and Language Options” section of the Windows Control Panel?

Active city is Ithaca NY, through zip code 14850.

Reigon is United States.


When you update the weather, I am assuming the date and time at the bottom of the forecasts is current?

Try installing the following Weather Watcher patch:

That’s wierd: it’s off by a week. It’s currently saying 11/22/2004, so it’s a week early.

I tried installing the patch again, but no effect. Same problem. Forecasts are still starting at 3am Tuesday.

Thanks for your patience with this. …


If you dbl click on the time in the Task Bar at the bottom of the screen what date is shown in the Date/TIme Properties window? And what is shown in the Time Zone box?


Date is today’s date.
Time is now’s time.
Timezone is correctly EST.


If that’s the case, then the weather information is not even being downloaded correctly.

Try the following:

  1. Are you using a firewall? If so, make sure it is giving Internet access
    to “C:\Program Files\Weather Watcher\DL.EXE”.

  2. Are you using an authenticated proxy server? If so, set your
    username/password in the “Proxy” section of the Weather Watcher Options.

(Due to some changes in Windows SP2, the following might fix the problem)

  1. Try running the following IE fix: