DL.exe problems

That says a lot - when the DL.exe locks up next, open a CMD window and try a PING or TRACERT and see if it goes anywhere.

I have a feeling that the reason hyperlinks stop working is actually because you net connection has fallen into some sort of extremely weird loop, blocking all incoming and outgoing connections. And if that is the case, then something happens when DL.exe is called to download the latest weather info that is leading to this situation…

That weird loop could be DL.exe. It tries to access the 'net, can’t for whatever reason; weather.com problem, user’s network problem, other pc sw such as a fw or av, and rather than exiting, sits there in the queue waiting to connect and blocking everything that comes after it.

Some more testing info…

Waited until DL.EXE locked up again… I could still check e-mail, etc. tracert and ping worked fine, browsing from my browser was fine… tried to click a hyperlink in an e-mail message… nothing happened… initially. After about 3 minutes, the page opened in my browser. So I tried it again… clicked a hyperlink in an e-mail message and nothing initially. This time it took about 4 and a half minutes, but the page finally opened. During those times, my e-mail app became non responsive waiting for the action to occur.

Now for the big one… DL.EXE has been locked up for over an hour (I waited that long just to be sure it was really locked up good). To try to see what else was going on, I opened Process Monitor from MS Sysinternals. I started examining the DL.EXE process using it, and lo and behold… it became unlocked and finished downloading weather updates. I don’t know exactly what I did or how, but I’m going to keep trying with Process Monitor to watch it and see what happens when it locks up from now on.

After more testing, DL.EXE is definitely the issue. For instance, I just had it lock up a few minutes ago; and selected ‘Visit Singer’s Creations’ from the WW context menu… my browser was already open, yet no page opened up… until I unblocked DL.EXE. Yes, I unblocked it!

It seems that DL.EXE does not have enough exception handling and is locking up waiting for responses from desktopfw.weather.com. I have been watching it while it is running using Wireshark(to examine the TCP packets) and TCPView from sysinternals (to keep an eye on the connections); and what happens is that DL.EXE sometimes misses the responses from desktopfw.weather.com or there are other TCP issues and DL.EXE does not recover from the errors. It then just sits there with an open connection to desktopfw.weather.com waiting… forever. When it is in this state, it causes the other issues like blocking hyperlinks or other programs opening web pages, blocking hibernation, etc.

With TCPView, however, I am able to close the open connection and DL.EXE unblocks and everything including WW returns to normal operation. After I’ve unblocked it, it will function normally until the next time some unhandled error causes it to lock up again.

So I believe adding some better exception handling to DL.EXE and possibly adding a default timeout to close the connection if it is left open will fix the problems.

Computer_Guru, this is actually how the DL.EXE was programmed. However, I found that the timeout procedure was not closing the connection – VB does not multitask very well.

The following zip contains an updated DL.EXE and GETFILE.EXE. Backup your existing DL.EXE and copy these new files into your Weather Watcher install folder.


Please let me know how this new DL.EXE responds. It should timeout after 30 seconds, rather than hang until the download completes and/or is manually terminated.

Since august I had a lot of problems with WW: the program retrieved the weather information the first time and then stopped working.
Now, with this new version of DL.EXE all seems ok.

Thanks Mike

PS: excuse my bad english

Ummm, maybe it’s me, but I don’t have a GetFile in my WW directory…

Of course this is also a brand new install (literally - just finished formatting and installing Vista yesterday) so maybe it hasn’t been ‘installed’ yet?

And another thing:

I installed WW, (5.6.24a) and then didn’t let it run the first time (which would have been with admin privileges due to the installer requiring admin privileges) and then I copied my old settings (citiycode, old wallpaper downloads, etc. that I had backed up before my format) and finally I extracted the dl.exe and GetFile.exe to the WW folder. I am not sure on the mechanism here, for I can think of a couple of reasons this occurred but…

When I ran WW and set up all my options, 1) WW didn’t exit out with an error like it used to, and 2) it downloaded the wallpaper without bugging me that it could not write to the folder (the path/file accesss error).

Now, it could be because I extracted the dl.exe and GetFile.exe directly from the zip file, although I had my filemanager open with admin privileges, or it could be that the files were not installed by the installer in the first place, meaning they may have inherited their privilege levels from me as opposed to from the installer - but at any rate, in Vista Ultimate I did not have the problem I usually have about the file path access error.

I’ll reboot and see if the problem manifests on a reboot, but if not, then either 1) you fixed something, or 2) I fixed something, or 3) perhaps manually running an installer with admin privileges (rather than letting the installer ask for the elevation via the system interface) eliminates that problem.

I’ll reboot and report back.

“GetFile.exe” is not part of the current Weather Watcher install. I had to add another layer to the download process in order to cause the update process to timeout. I more-or-less just wanted to test the code out before I integrated it into the WW.EXE.

This fix is working perfectly. I’ve tried everything to block dl.exe and it works like a champ. I’ve changed the update frequency to 5 minutes, tried it while running heavy TCP traffic, even used it while downloading several large items with uTorrent… it’s working great.

Just what I needed so thankfully I get to use WW again.

Thanks very much.

Computer_Guru, I’m happy to hear you’re back up and running again. I appreciate the extensive information too – very helpful! Please keep me updated if you run into any more trouble with DL.EXE.

Quick bit 'o info related to DL.EXE – it’s probably minor and not worth starting a new topic unless you prefer it. When WW (5.6.24a) checks for updates, the check at http://www.thawkins.com/donated/VERSION.TXT returns a 403 “forbidden” error page. Probably just a mistake with permissions.

What got me to check it manually with my browser was a firewall prompt for JavaScript from that site right after a forecast update. It didn’t make sense to have JS for a version number textfile unless they were doing more than hosting your file. :icon_smile:

Landroid, thank you. I took care of that.

Thank you sir!