CPU goes crazy with WW 5.6.24

The CPU is at 100 % when I load the WW at at the task menager it says ww.exe is up to 92 95%
when I load it it is ok, it shows me the old measure from yesterday and it does not retrieve any data… I make it retrieve data and then the problems starts…
I have to stop it and when I load it again it shows me the updated weather, but when it starts to update again… the CPU goes crazy again,

by the way, this is on my new comp which I bought two days ago… all other stuss works just fine, only WW acts odd…

What OS are you running? Vista? What version of WW are you running? 5.6.24a?

Check the computer’s safe guard sw; av, fw and etc, to see if one of them is blocking DL.exe or the IP addresses WW uses. DL.exe is the program that WW uses to obtain the weather.com data.

nikistoychev, did you try the following Weather Watcher build?

thank you for your replies, I have XP SE, and tried the version which Mike suggests, the CPU is ok now, but it does not oen the WW window… so I can not have a look at the weather by hours,
funny, though…
it is not the programm I think, as it works fine when I installed it on 98 and 2000, hhhhmmmm
anway, thank you for your kindest and prompt replies, Nik,

Try restarting Weather Watcher by choosing “Exit” from the Weather Watcher system tray menu. If you cannot access that menu, then close down Weather Watcher from the “Applications” tab of the Windows Task Manager. You can access the Windows Task Manager by pressing CTRL+ALT+DEL.

If the 26a version displayed the forecasts and the 26s version doesn’t, on the same system, I would check the system’s safe guards again. Some safe guards consider new version’s of an app as a new app and block them.

thank you very much for your replies. in fact I tried your suggestions but no success,
so I opened the program files, after deinstalling WW and deleted the remnants off files… then re-installed the program WW5624S and works fine…
so simple deinstall is no good… you have to manually delete the files… there is a prompt when you reinstal fo r overwriting, but evidently it breaks the system, or at least does it here…
so, deinstall, delete, and reinstal again,
thanks again…